5 Replies Latest reply on May 15, 2009 3:20 AM by jmaxwell

    Update Failed (MCScript_InUse gets stuck?)

      Hi All,

      I have been having some problems with updating some of the machines in the estate and wonder if anyone has a solution.

      We had this problem when we were using agent version 3.6.0.453, which apparently had lots of problems, so McAfee suggested that we go to 3.6.0.608, but we were still having the same issues with update. Therefore, we went onto deploy agent 4.0.0.1345, again, only a half of the machines were updated with DAT and Agents (we have about 3000 machines).

      Having looked into a few machines, I found that if I stop the process McScript_InUse, (only able to do so by using DrWtsn32 -p command, pskill / net stop will say Access Denied) the update will then be successful. It looks as though McScript_InUse is somehow stuck?

      Looking at the agent log, it keeps repeating the message "Update will start in {x} minutes because update is in progress".

      Sometimes, I will have to restart Frame Work Service as well.

      Does anyone know how I could correct this fault? There's no way I could go round 1500 machines and manually kill this process. Reboot is not an option, as these are machines that are required for 24/7.

      Appreciate any help.

      Thanks,

      Jon
        • 1. RE: Update Failed (MCScript_InUse gets stuck?)
          Laszlo G
          I suppose you have created a deployment task to install MA 4.0 on these machines so you can try this on one of these machines:

          - Disable deployment task for this machine
          - Send an activation for that it downloads new task
          - Enable deployment task again for this machine
          - Send another activation for getting again the task change.

          Have a llok at agent log to see if it now updates or not, I'va had to do this sometimes because the task got stuck and the only way to stop it was disabling it first.

          By the way, "McScript_InUse" is the process used for deployments
          • 2. RE: Update Failed (MCScript_InUse gets stuck?)
            Thanks for your reply, still no joy.
            It just keep saying "The update task will be re-tried in x minutes because update is in progress."
            Does anyone know how to use the command line to uninstall VSE8.5i?
            In the meantime, I'll keep searching~~

            Thanks
            • 3. RE: Update Failed (MCScript_InUse gets stuck?)
              Thought I'd update this as it might help in the future for others:

              After much investigation / research, we now have a workaround for this.
              First disable the option "Prevent McAfee services from being stopped" within Access Protection Policies. Apply this for both for Workstation and Server in the drop down menu.

              Wait for the new policy to take place (usually after the agent wakeup, which should be every hour, by default).

              Download "kill.exe" from the internet, copy onto the target machines (we have a deployment software so it makes thing easier).

              Run the following batch:

              kill.exe -f FrameworkService
              kill.exe -f Mcshield
              kill.exe -f McScript_InUse

              net start "McAfee Framework Service"
              net srart "McAfee McShield"

              Once the services restarted, the update will take place automatically.

              This might have been covered before, but I couldn't find anything in search, hope it'd be useful for someone one day.
              • 4. Update Failed (MCScript_InUse gets stuck?)
                When I try to update the DATs, manually or automatically, it fails. When I look in event viewer it shows a McLogEvent Event ID 258 "The update failed; see event log". Why won't the software update?
                • 5. RE: Update Failed (MCScript_InUse gets stuck?)
                  jmaxwell


                  What does the relevant section of the agent log on the failig clinet show during the update attempt ?