3 Replies Latest reply on Feb 1, 2009 7:33 PM by iamjeff

    ePO 4.0 upgrade (database)

      Hi all,

      I'm planning to upgrade ePO 3.6.1 to 4.0. According to KB51317 <ePO 4.0 Known Issues - Installation and Upgrade>, it states that "During an upgrade if you select a database server with an existing ePO database, you are prompted whether to delete it. Before answering yes, be sure that the database has been backed up if needed. To select a different database server, answer no."

      If ePO 4.0 upgrade will delete existing database, how can it migrate all data, policies, tasks and events? Or the upgrade will migrate existing database to a new database for ePO 4.0 and then detele existing database? I'm confused about the database upgrade. Thanks.
        • 1. RE: ePO 4.0 upgrade (database)
          pwolfe
          I ran the upgrade less than a month ago. I do not remember seeing this issue. But that does not meen it wasn't there.

          It did Migrate All data & Policies accordingly. It was a bit to get used to after the old MMC interface. (Much Nicer with EPO 4.0"WEB INTERFACE")

          I did run a backup of the EPO Database (Just in case) using a batch file as follows: (You will need to modify the script a bit if you are running the same database backend and add the correct password @ PASSWORD & Path of you're McAfee this is the Script for the New Location of EPO 4 not 3 ...


          If you have questions....just ask...
          ###########################################################
          Z:
          cd \
          mkdir EPO_BACKUP
          cd EPO_BACKUP

          mkdir DB_FOLDER
          cd DB_FOLDER
          del *.* /s /q
          cd \

          C:
          cd \
          CD "\Program Files\McAfee\ePolicy Orchestrator"

          osql -U sa -P PASSWORD -S TD-EPO\EPOSERVER -n -Q "BACKUP DATABASE [ePO_TD-EPO] TO DISK = 'z:\EPO_BACKUP\ePO_TD-EPO.bak' WITH INIT,SKIP"

          xcopy /e /c /y "C:\Program Files\McAfee\ePolicy Orchestrator\DB\*.*" Z:\EPO_BACKUP\DB_FOLDER\

          exit
          ###########################################################
          • 2. RE: ePO 4.0 upgrade (database)
            You should say no to that and keep the 3.6.1 database until you are confident that ePO 4.0 is working as you expect. You can always remove the database later.

            Joe
            • 3. RE: ePO 4.0 upgrade (database)


              Any dtabase server is a separate sql 2005 server. If I choose "NO" to select different database, will it install a new database without data migration? Because I need to keep All Data & Policies.

              Thanks all!