4 Replies Latest reply on Jan 30, 2009 6:21 AM by dbrigham

    ePO 3.6.1 Upgrade To 4.0 -- No Database?

      Well, finally upgraded from 3.6.1 to 4.0 today.

      All seems to have gone well *except* that the database from 3.6.1 did not get migrated.

      I think that I know why -- the database on 3.6.1 did not have the standard "ePO_{server}" name -- we had used a different name a year ago when we moved from a local MSDE database to an SQL-Server database on an external server cluster. The new database then was named "EPO."

      During the upgrade I was asked to verify the SQL-Server name and credentials, I did, and the upgrade proceeded. But I was never asked for the database name, and I think that the ePO 4.0 install did not see the expected name, so it created it.

      So I am up now with what seems to be the correct software, policies and tasks (I'm managing our 2000 nodes), but no historical data and only three queries.

      On the database server I see the old database and the new database.

      So -- how do I shove the old data into the new database?

      Thanks!

      Dana Brigham
        • 1. RE: ePO 3.6.1 Upgrade To 4.0 -- No Database?
          akl71

          You must migrate the events to the new database.
          Automation -> new task -> event migration
          • 2. RE: ePO 3.6.1 Upgrade To 4.0 -- No Database?
            Hi dbrigham, I'm planning to upgrade ePO 3.6.1 to 4.0. Did you use the in-place upgrade method for ePO upgrade? I also concern about the database upgrade because I'm not sure whether the upgrade process will delete and overwirte existing database or not, OR keep the existing database? Thanks.
            • 3. RE: ePO 3.6.1 Upgrade To 4.0 -- No Database?


              Well -- I did that, as the upgrade guide says -- it ran for 3 seconds and no historical events were migrated.

              Since our old database (13GB, 1-year of data) had a nonstandard database name, could that be the issue?

              If so, how do I run that Event Migration task but have it pull from the old database properly?

              Thanks -- Dana
              • 4. RE: ePO 3.6.1 Upgrade To 4.0 -- No Database?


                In-place. I backed up the original database (stored in SQL-Server on a separate server), and I have that, as well as the original database sitting out there, along with the new database.

                But our old database had a custom name (just "EPO") that happened when we moved from the local install of MSDE to SQL-Server -- so that database name did not match the standard naming that ePO uses (ePO_{server name}) -- and when I ran the upgrade it prompted me to confirm the database server name, the authentication credentials, but *NOT* the database name. So I think that the upgrade just assumes the standard database name and didn't even touch our old database.

                I'm trying to get McAfee tech support to confirm that now....

                Dana