6 Replies Latest reply on Mar 17, 2017 1:52 AM by cwk1992

    NaInet library returned code == -9

    cwk1992

      Hi All,

       

      Previously i had installed epo agent on a windows 7 machine without any problem.

      But after some time, when i reopen back the epo server, i noticed that all of the agents are showing an outdated last communication date.

       

      When i check on the client machine, the installed agents shows that it failed to connect to the ePO Server in the Agent Status Monitor.

      However, when i tried to wake up the agent from the server, it was successfully executed without any error.

       

      Below are the logs taken from the agents.

       

      2017-03-08 16:53:18.085E#6888ServiceMgrError trace:
      2017-03-08 16:53:18.085E#6888ServiceMgr  Not persisting SAHU_SERVER stat data. It is either invalid or not running currently
      2017-03-08 16:53:37.962E#6580imsiteError trace:
      2017-03-08 16:53:37.962E#6580imsite [uploadFile,,/spipe/pkg?AgentGuid={72C80A8B-5241-4B46-A7B7-DB7DC4F6AE7B}&Source =Agent_3.0.0,pkg00131334368117260000_4016888937.spkg,C:\ProgramData\McAfee\Commo n Framework\Unpack,C:\ProgramData\McAfee\Common Framework\Unpack\pkg00131334368128100000_1721308088.spkg]->
      2017-03-08 16:53:37.962E#6580imsite  NaInet library returned code == -9
      2017-03-08 16:53:37.962E#6580imsiteError trace:
      2017-03-08 16:53:37.962E#6580imsite [uploadFile,,/spipe/pkg?AgentGuid={72C80A8B-5241-4B46-A7B7-DB7DC4F6AE7B}&Source =Agent_3.0.0,pkg00131334368117260000_4016888937.spkg,C:\ProgramData\McAfee\Commo n Framework\Unpack,C:\ProgramData\McAfee\Common Framework\Unpack\pkg00131334368128100000_1721308088.spkg]->
      2017-03-08 16:53:37.962E#6580imsite  NaInet library returned code == -9
      2017-03-08 16:53:37.962E#6580imsiteError trace:
      2017-03-08 16:53:37.962E#6580imsite [uploadFile,,/spipe/pkg?AgentGuid={72C80A8B-5241-4B46-A7B7-DB7DC4F6AE7B}&Source =Agent_3.0.0,pkg00131334368117260000_4016888937.spkg,C:\ProgramData\McAfee\Commo n Framework\Unpack,C:\ProgramData\McAfee\Common Framework\Unpack\pkg00131334368128100000_1721308088.spkg]->
      2017-03-08 16:53:37.963E#6580imsite  The naInet library returned an error. [Parent error: NaInet library returned code == -9]
      2017-03-08 16:53:42.969e#6580AgentAgent failed to communicate with ePO Server
      2017-03-08 16:53:48.154E#6580imsiteError trace: