6 Replies Latest reply on Jan 19, 2009 4:18 AM by JillesRetera

    Some PCs don't show up in EPO

      I'm sure I've just missed other posts about this, so please excuse my forum searching skills but I can't find a solution.

      I have PCs and Servers that just drop out of EPO. Many times my Vista box has disappeared but I have had many other PCs stop showing up and some don't show up when they are added to the network.

      I have used the domain tree (Systems -> New systems -> browse) to find them and tried going to the netbios name and\or the ip directly (Quick System search). None of these work sometimes.

      I've even had some that were NOT attached to the domain that DID show up!

      The only way I have found to add them to EPO is to go to the PC and manually install the agent. Even then! I have had issue with them staying in EPO.

      I cannot have PCs dropping out of EPO especially if I can't easily add them back in.

      So, am I doing something wrong or is this normal? How can I fix it?
        • 2. RE: Some PCs don't show up in EPO
          Thanks for the reply djjava9.
          I think you may have skipped through my posting a little bit. This link to the intro video is great when everything works as expected. It was one of the first things I tried.
          Unfortunately, this isn't my problem. The problem is that I can't get the machines to show up doing exactly what the video says to do.
          I need to know how to make EPO “See” the computers on my domain when the basics are not working.
          • 3. RE: Some PCs don't show up in EPO
            Sk1dMARK
            I’ll preface my reply by saying that I am running ePO 3.6.1 P4, so you may need to extrapolate a little.

            The only time I have ever seen machines “disappear” from the ePO directory is due to duplicate AgentGUIDs.

            Were your machines created from imaging software? If so, you need to delete the AgentGUID registry value before making the image.

            To test this theory:
            Connect to the server where ePO is installed and get a known-good CMA (framepkg.exe) from the software DB.

            Now, logon to a machine exhibiting the problem and do a manual install of the CMA you just pulled from the server (framepkg.exe /install=agent /forceinstall). This will completely remove the prior agent install and give you a new agent install with a new AgentGUID.

            Then open a command prompt and navigate to the CMA install directory. Once there type (cmdagent.exe /s) to invoke the Agent status monitor. Now press the top button “Collect and Send Props”. Watch the dialog and make sure you are getting no errors in communication or otherwise.

            Finally, go and check ePO to see if your machine is showing up.

            Did it show up? If so, does it stay? If so, I believe your problem is Duplicate AgentGUIDs. If not, I would contact McAfee support and open a ticket.


            Regards,

            Mark
            • 4. RE: Some PCs don't show up in EPO
              twenden
              I am running EPO 3.6.1 Patch 4 like you. The only time that I see systems disappear is due to duplicate agent guids.

              To find these duplicates McAfee has a knowledge base article #KB55010 that explains some SQL query scripts that you can use to find them. I put those scripts into a batch file that I run on the EPO server in a command prompt. It has helped me several times find groups who are using ghost with software images that have the agent guid in them.

              Below is the link to this article.

              https://kc.mcafee.com/corporate/index?page=email_content&pmv=print&locale=en_US& actp=email&id=KB55010
              • 5. RE: Some PCs don't show up in EPO
                I'll post the results the next time I get a PC that drops off.
                The duplicate AgentGUIDs sure sounds right but I'm reasonablely sure the Vista box I have was not Ghosted. (I've inherited this issue from a former employee.)
                We do use Ghost though.

                Also, I looked over my posts and realized I forgot a couple of important items.

                I'm on EPO 4.
                I used 8.5i and 8.7 and had the same issue.
                I have NOT seen this in 2 environments I manage that don't use Ghost which is why I'm leaning towards Ghost being the issue.
                I'll gladly take any other ideas too!
                Thanks.
                • 6. duplicates
                  99 out of 100 times this is a duplicate indeed...
                  Just run the query in the reports section of the epo server.

                  If there are no agents coming up out of this query, it could be a firewall / security issue.