0 Replies Latest reply on Dec 8, 2008 9:04 AM by mcdave

    errors installing epoFrameworkservice

    mcdave
      We've got a few clients on which epoframeworks won't install.

      Here is a log from one of the most common issues from our clients:
      error 2: The system cannot find the file specified.

      log:

      20081208153607 I #2256 Stub Pkg
      20081208153607 I #2256 Stub Pkg START ["FramePkg_US.exe" /silent /forceinstall /install=agent ]
      20081208153607 I #2256 Common Pkg CreateDirectory (C:\WINDOWS\TEMP\unz34E.tmp)
      20081208153607 I #2256 Stub Pkg System=1
      20081208153622 I #2256 Common Pkg CreateProcess (C:\WINDOWS\TEMP\unz34E.tmp\FrmInst.exe, /silent /forceinstall /install=agent /FramePkg /Cleanup="C:\WINDOWS\TEMP\unz34E.tmp" /LOGDIR="C:\WINDOWS\TEMP\NAILogs")
      20081208153622 I #2256 Common Pkg WaitForSingleObject (C:\WINDOWS\TEMP\unz34E.tmp\FrmInst.exe, -1)
      20081208153623 I #520 naCmnLib Ins Random seed = 0xb0ae****
      20081208153623 I #520 Setup Ins START [/silent /forceinstall /install=agent /FramePkg /Cleanup="C:\WINDOWS\TEMP\unz34E.tmp" /LOGDIR="C:\WINDOWS\TEMP\NAILogs"]
      20081208153623 I #520 Setup Ins Windows 5.1.2600 Service Pack 2
      20081208153623 I #520 Setup Ins Attempting to perform a setup operation
      20081208153623 I #520 UI Ins Starting setup...
      20081208153623 I #520 UI Ins Validating setup options...
      20081208153623 E #520 Xml Ins Error trace:
      20081208153623 E #520 Thread Ins [Main thread]->
      20081208153623 E #520 Setup Ins [Attempting to perform a setup operation]->
      20081208153623 E #520 Script Ins [Script generation]->
      20081208153623 E #520 Cmalib Ins [Update manifest product count]->
      20081208153623 E #520 Xml Ins [useExistingFile,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\FrameworkManifest.xml]->
      20081208153623 E #520 Xml Ins [ReadBufferFromFileNoExp,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\FrameworkManifest.xml]->
      20081208153623 E #520 Xml Ins Couldn't open to read: No such file or directory
      20081208153623 E #520 Xml Ins Error trace:
      20081208153623 E #520 Thread Ins [Main thread]->
      20081208153623 E #520 Setup Ins [Attempting to perform a setup operation]->
      20081208153623 E #520 Script Ins [Script generation]->
      20081208153623 E #520 Xml Ins [useExistingFile,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\FrameworkManifest.xml]->
      20081208153623 E #520 Xml Ins [ReadBufferFromFileNoExp,C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\FrameworkManifest.xml]->
      20081208153623 E #520 Xml Ins Couldn't open to read: No such file or directory
      20081208153623 I #520 Script Ins Unable to open C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\FrameworkManifest.xml. Therefore CMA is not installed.
      20081208153623 I #520 Script Ins C:\Program Files\McAfee\Common Framework\aginst32.exe is not present. Therefore the 2.x agent is not installed.
      20081208153623 I #520 Script Ins Unable to get the FtpSite node from C:\WINDOWS\TEMP\unz34E.tmp\SiteList.xml
      20081208153623 I #520 Script Ins Unable to get the UNCSite node from C:\WINDOWS\TEMP\unz34E.tmp\SiteList.xml
      20081208153623 I #520 Script Ins The state of script is:
      20081208153623 I #520 Script Ins Installed = FALSE
      20081208153623 I #520 Script Ins ManagedMode = FALSE
      20081208153623 I #520 Script Ins InstallFilesAndRegistry = TRUE
      20081208153623 I #520 Script Ins InstallAgentRegistry = TRUE
      20081208153623 I #520 Script Ins RemoveFilesAndRegistry = FALSE
      20081208153623 I #520 Script Ins CleanupFiles = FALSE
      20081208153623 I #520 Script Ins RemoveAgentRegistry = FALSE
      20081208153623 I #520 Script Ins IncrementUpdaterRefCount = FALSE
      20081208153623 I #520 Script Ins DecrementUpdaterRefCount = FALSE
      20081208153623 I #520 Script Ins PutCmaIntoManagedMode = TRUE
      20081208153623 I #520 Script Ins RemoveCmaFromManagedMode = FALSE
      20081208153623 I #520 Script Ins ReplaceNaiRepositories = FALSE
      20081208153623 I #520 Script Ins ReplaceEpoSite = FALSE
      20081208153623 I #520 Script Ins ReplaceSiteList = TRUE
      20081208153623 I #520 Script Ins Remove3xServerTasks = FALSE
      20081208153623 I #520 Script Ins Remove2xAgent = FALSE
      20081208153623 I #520 Script Ins RunHigherVersionedRemove = FALSE
      20081208153623 I #520 Script Ins WaitForCmaToFinish = TRUE
      20081208153623 I #520 Script Ins RunHigherVersionedSetup = FALSE
      20081208153623 I #520 Script Ins SingleTrayIcon = TRUE
      20081208153623 I #520 Script Ins NumberOfProductsUsingCMA = 0
      20081208153623 I #520 Script Ins InstalledPath = 'C:\Program Files\McAfee\Common Framework'
      20081208153623 I #520 Script Ins TargetInstalledPath = 'C:\Program Files\McAfee\Common Framework'
      20081208153623 I #520 Script Ins DataPath = 'C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework'
      20081208153623 I #520 Script Ins TargetDataPath = 'C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework'
      20081208153623 I #520 Script Ins HigherVersionedSetup = 'C:\Program Files\McAfee\Common Framework\FrmInst.exe'
      20081208153623 I #520 Script Ins FrameworkVersion = ''
      20081208153623 I #520 Script Ins SiteList = 'C:\WINDOWS\TEMP\unz34E.tmp\SiteList.xml'
      20081208153623 I #520 UI Ins Checking for necessary rights...
      20081208153623 I #520 UI Ins Waiting up to 4 minutes for current update session to finish.
      20081208153623 I #520 UI Ins Stopping processes if necessary...
      20081208153634 I #520 Exec Ins Disable CMA service
      20081208153634 E #520 Service Ins Error trace:
      20081208153634 E #520 Thread Ins [Main thread]->
      20081208153634 E #520 Setup Ins [Attempting to perform a setup operation]->
      20081208153634 E #520 Exec Ins [Setup execution]->
      20081208153634 E #520 Exec Ins [Disable CMA service]->
      20081208153634 E #520 Service Ins [ChangeServiceConfig,McAfeeFramework]->
      20081208153634 E #520 Service Ins error 2: The system cannot find the file specified.
      20081208153634 I #3396 Main Cle
      20081208153634 I #3396 Main Cle START [3948 0 /LOGDIR="C:\WINDOWS\TEMP\NAILogs" "C:\WINDOWS\TEMP\unz34E.tmp" ]
      20081208153634 I #3396 Common Cle WaitForSingleObject (MCAFEE_FRAMEWORK_CLEANUP_INSTANCE, -1)
      20081208153634 I #3396 Common Cle OpenEvent (MCAFEE_FRAMEWORK_CLEANUP_MUTEX_CREATED)
      20081208153634 E #520 UI Ins Error trace:
      20081208153634 E #520 Thread Ins [Main thread]->
      20081208153634 E #520 UI Ins There was an unexpected error during setup execution. See this log file for details: C:\WINDOWS\TEMP\NAILogs\FrmInst_PCName.log
      20081208153634 I #520 Thread Ins Exit program
      20081208153634 I #520 Setup Ins END 1603
      20081208153634 I #3396 Common Cle WaitForSingleObject (calling FrmInst.exe, -1)
      20081208153639 I #2256 Stub Pkg END 1603
      20081208153639 I #3396 Main Cle END 0