2 Replies Latest reply on Jan 27, 2017 6:40 AM by Unblack

    FTP Problems

    Unblack

      Hi, does anyone else have issues with ftp?

      We have a very slow ftp transfer, many disconnections.

      List directory problems on huge folders.

       

      The support investigates the problem. But it would be interesting if anyone else have similar problems.

      This problem occurred recently.

      (WGW 7.7.0.3 and 7.6.2.6 - diffrent locations)

        • 1. Re: FTP Problems
          Jon Scholten

          Hi Unblack,

           

          Do you have any public examples you can share by chance? (i.e. ftp://ftp.hp.com/pub/ or ftp://ftp.dell.com/)

           

          Do you know if you have progress indication enabled for FTP traffic? Is your problem with uploads or downloads? You said directory listings, so that's a download of sorts..

           

          If it's with uploads, back in 7.4 or 7.5, we introduced upload progress indication. This is included with the Progress Indication ruleset which is in the ruleset library.

           

          If you get a tcpdump to support, they should be able to diagnose the issue. Nothing in MWG should have fundamentally changed with FTP handling.

           

          Do you recall if it started after an upgrade?

           

          Best Regards,

          Jon

          1 of 1 people found this helpful
          • 2. Re: FTP Problems
            Unblack

            Hi,

            the problem occurs even if the ftp host is in the global whitelist.

            Progress indication is enabled. The Problem ist with uploads and downloads.

             

            ftp.hp.com works fine! Fast

             

            ftp.dell.com - same problem - hangs on  "150 File status okay; about to open data connection."

            It takes a very long time to list the directory. Sometimes i get a timeout.