2 Replies Latest reply on Oct 20, 2008 12:43 AM by Shads

    ePO 3.6.1 to 4.0 upgrade.  Failing on SQL, AFTER the sql check

      We're currently running 3.6.1 on a server which has sql2005 installed, but epo is looking at a remote sql instance. No problems with this, it all works fine.

      When trying to upgrade to 4.0, I initially encountered the TCP port error on the sql check, which is solved by editing the server.ini file in the DB folder of the epo installation. A bit of googling shows this occurs because the sql server returns the full instance name rather then the alias, which is set. (and confirmed from the logs)

       

      Server names DO NOT MATCH so block the install.
      Servername from SQL server : [SQLSERVER\EPO3]
      Servername from installer : [EPO3]



      So editing the .ini file to match solves this particular problem, and the log file shows a bunch of tests performed with creating the new tables etc all being successful after entering the sql username/pw

      I am then presented with the list of ports that need to be used for communication (all are open , no firewall between these servers) Clicking next on this presents me with the following error:

       

      FAILURE: Unable to connect to the SQL server while trying to get the Notification Information.



      Checking the log file, I see the following, which is AFTER the successful sql connection/test table creation part (So I know that I can connect succesfully)

       

      20081017111347 Calculating the DataSource for your SQL server.
      20081017111347 UDP port is not enabled so configuring DataSource to use port number instead.
      DataSource used: [SQLSERVER,1433]
      20081017111347 Setting connection string DataSource to [SQLSERVER,1433].
      20081017111347 Connection string set for SQL Authentication database connection.
      20081017111347 SQL::connect to server SQLSERVER\EPO3
      20081017111347 Testing SQL Authentication to SQL Server.
      20081017111347 Failed to connect to SQL Server [SQLSERVER\EPO3] with error code [0x80040e4d]
      20081017111347 Description for error code is [Login failed for user 'mcafee'.]



      During the first sql test, where you enter the credentials, the log file shows that UDP port is enabled, and the datasource is set to the instance of the database, but if you look in the above part, it suddently decides udp isnt available, and sets the datasource to just the sqlserver itself (but still trys for the instance)

      Ive tried with both windows authentication and sql authentication (as DBO permission. Both pass the initial test, but fail on this notification section. I'm able to connect via odbc and sql manager to the instance correctly, machines are not firewalled and are on same subnet. Using the sql tool cliconfg, I've tried every manner of alias, which hasn't helped.

      I'm left with the opinion that seeing as the initial sql connection is made, test databases initialised etc, that its nothing to do with the sql setup. So.. can anyone help? sad