8 Replies Latest reply on Jun 2, 2009 5:14 PM by WarEduar

    ePOPolicyMigration tool not working

      I recently added VSE 8.7 and AntiSpyware 8.7 on an ePo Orchestrator 4.0 and added the extensions.

      I was happy reading about the ePOPolicyMigration tool, because we have quite a lot of policies. When I try to run the ePOPolicyMigration tool its just quiet, nothing seems too happen and when I check Systems -Policies VSE 8.7 only the default policies are present.

      Can anyone help me understand?
        • 1. RE: ePOPolicyMigration tool not working
          tonyb99
          there is no dialogue you just log onto the epo server and run this from a local drive, check the readme section for VSE 8.7 which has more info on issues and with having vse 8.0 checked in etc
          • 2. RE: ePOPolicyMigration tool not working
            Thank you for your answer Tony!

            I have checked the readme before and even though I had both 8.0 and 8.5 checked in it should work according to the readme just to execute the tool locally as I did, because if I wanted to upgrade 8.0 I had to add the /force80 switch and I did not.

            After the first attempt I removed VSE 8.0 from the server and tried again but with no luck. Now I am afraid of this line in the readme: "The Policy Migration tool only runs one time per server". Is it one time or one successful migration?

            Help needed!
            • 3. RE: ePOPolicyMigration tool not working
              Is there maybe a -Debug mode or something to check what does not work?
              • 4. RE: ePOPolicyMigration tool not working
                Hi!

                I have some configuration and problem, but my ePO server is installed on VMWare ESX Server virtual machine.
                When I try to run the ePOPolicyMigration tool it's just quiet, nothing seems too happen.
                • 5. RE: ePOPolicyMigration tool not working
                  I'm try to log all SQL queries:

                  1. First SQL:
                  SELECT EPOPolicySettings.PolicySettingsID
                  FROM EPOPolicySettings, EPOPolicyTypes
                  WHERE EPOPolicyTypes.FeatureTextID LIKE 'VIRUSCAN8700'
                  AND EPOPolicyTypes.TypeTextID = 'VSC700_BehaviorBlock_Policies'
                  AND EPOPolicyTypes.TypeID = EPOPolicySettings.TypeID
                  AND EPOPolicySettings.Name = 'McAfee Default'

                  result: 211

                  2. Second SQL:
                  SELECT SettingValue
                  FROM EPOPolicySettingValues
                  WHERE PolicySettingsID = 211
                  AND SectionName = 'ePOPolicyMigration'
                  AND SettingName = 'MigrationHappened'

                  result: NULL

                  3. Then ePOPolicyMigration.exe is stoped.
                  • 6. I finally got this utility to run
                    flitcraft33
                    OK, so after much soul searching I went to the right directory which was NOT easy to find and is not in any McAfee documentation that I can find, and ran the utility. It worked instantly. There was no feeedback from it whatsover. Here is the path that worked for me;

                    C:\Program Files\McAfee\epo40\Server\extensions\installed\VIRUSCAN8700\8.7.0.141\tools

                    Hope this helps. It is totally not what the documentation seems to indicate. I ran other wrong copies before this one, so who knows what damage I have done. I noticed that this program also exists an 8.5.0 directory structure, as well as in a bunch of temp directories, so be careful to get the right one. I make no promises and accept no responsibility for this, so if you are stuck until 2 AM rebuilding your ePO server due to my advice, you're on your own!

                    Cheers,
                    Dan Sichel
                    Ponderosa Telephone
                    • 7. RE: ePOPolicyMigration tool not working


                      I had the same issue. I had 8.0, 8.5 and 8.7 installed. 8.0 had all my policies, i had 8.5 installed to test. I then decided i wanted to roll out 8.7 but wanted to migrate all my polices from 8.0 to 8.7. I ran the migration tool ePOPolicyMigration.exe without the switch ePOPolicyMigration.exe /force80

                      This meant all my 8.7 polices took from 8.5 instead of the policies from 8.0.

                      To resolve i removed all extention and packages for 8.5 and 8.7, restarted the server, checked in 8.7 and added to repository. I then ran ePOPolicyMigration.exe /force80 and all my policies in 8.0 also now apply to 8.7.
                      • 8. RE: I finally got this utility to run


                        OMFG

                        Thx dude works for me....i really love you! you saved my ***.