8 Replies Latest reply on Sep 24, 2008 7:05 AM by Charlz

    Error when modifying MyAvert settings

      Whenever I change a setting in the MyAvert settings on ePO 4.0 I get a message saying "An unexpected error occured." and I'm back to the dashboard. When I go back to check the settings of MyAvert, they are changed to what I set but MyAvert is not working. Port 8801 from ePO server to avertlabs is open. I'm wondering what might be the cause...
      Any help is appreciated, I tried looking at the logs but didn't see anything related to this. Can anyone point me to where these events are logged?

      Thank you!
        • 1. RE: Error when modifying MyAvert settings
          tonyb99
          there should be entries in the orion.log relating to the problem, can you post the relevant bit.
          %install location%\server\logs\orion.log
          • 2. RE: Error when modifying MyAvert settings
            Ok, this is what is generated in the log when the unexpected error occurs.

            2008-09-23 11:23:39,963 ERROR [http-8443-Processor21] [/AvertAlerts].[PolicyMgmt] - Servlet.service() for servlet PolicyMgmt threw exception
            java.lang.NullPointerException
            at com.mcafee.epo.avertalerts.daemon.AvertService.stop(AvertService.java:154)
            at com.mcafee.epo.avertalerts.avertsetting.AvertAlertSettings.SaveAvertSettings(AvertAlertSettings.java:239)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            at java.lang.reflect.Method.invoke(Method.java:597)
            at com.mcafee.orion.core.servlet.mvc.MvcActionFactoryBase.executeAction(MvcActionFactoryBase.java:58)
            at com.mcafee.orion.core.servlet.ControllerServlet.executeAction(ControllerServlet.java:139)
            at com.mcafee.orion.core.servlet.ControllerServlet.processRequest(ControllerServlet.java:85)
            at com.mcafee.orion.core.servlet.ControllerServlet.doPost(ControllerServlet.java:56)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
            at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
            at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
            at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
            at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
            at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)
            at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:525)
            at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
            at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
            at org.apache.catalina.valves.FastCommonAccessLogValve.invoke(FastCommonAccessLogValve.java:482)
            at com.mcafee.orion.core.server.AjaxValve.invoke(AjaxValve.java:84)
            at com.mcafee.orion.core.server.OrionUserSetupValve.invoke(OrionUserSetupValve.java:54)
            at org.apache.catalina.authenticator.SingleSignOn.invoke(SingleSignOn.java:420)
            at com.mcafee.orion.core.server.OrionSingleSignOn.invoke(OrionSingleSignOn.java:104)
            at com.mcafee.orion.core.server.ParameterEncodingValve.invoke(ParameterEncodingValve.java:37)
            at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
            at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
            at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:874)
            at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:665)
            at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
            at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
            at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:689)
            at java.lang.Thread.run(Thread.java:619)
            • 3. RE: Error when modifying MyAvert settings
              Well that's quite clear isn't it ;)

              What patch version are you currently running?

              Can you describe what kind of changes you are trying to set?


              Updating:
              Proxy:
              Proxy server:
              Proxy authentication:
              • 4. RE: Error when modifying MyAvert settings
                tonyb99
                Are you on patch 2 for epo 4.0 and did this install first time without failing on any of the extensions?
                • 5. RE: Error when modifying MyAvert settings
                  Whatever changes I do in the MyAvert settings makes that unexpected error... I opened a ticket yesterday at McAfee support and they checked with me on the server and they couldn't find why it was doing that error. The support guy told me he would check with his backend team and update me through emails...
                  • 6. RE: Error when modifying MyAvert settings


                    Then i assume that the answers to this question would be YES and YES?
                    • 7. RE: Error when modifying MyAvert settings
                      Yes and yes
                      • 8. "Unexpected Error..."
                        David.G
                        Hi,

                        Any on ever came up with a solution for this problem? I'm experiencing the same error when trying to get into the Task section, whether global task or individual.

                        I've been running patch 4 for over a week and this is the first glitch since then. Not sure if it's related. It's the first time I encounter this.

                        Of course, Orion.log in full of error entries but nothing that would lead 'me' to a resolution. Browser and services (all) have been restarted with no effect. everything else seems to be working normally.

                        Just bracing myself for 1h+ hold time with support... Any alternative help would be much appreciated. Thanks.

                        Dave.