9 Replies Latest reply on Nov 17, 2016 5:10 AM by awnishkumar643

    Need to upgrade EPO 4.5

    awnishkumar643

      Dear All,

       

      Hope everyone is doing well.

       

      Im very new to McAfee and i have joined a company who are running McAfee EPO version 4.5, and they need to upgrade their EPO to the latest version, but one condition that the upgrade should be done only once. For example from 4.5 to 4.6 or any applicable version.

       

      Please guide and suggest.

       

      Early reply will be really helpful.

       

      Thanks and Regards,

      Awnish.

        • 1. Re: Need to upgrade EPO 4.5
          Dutchman39

          I was in the same position - almost - a couple of years ago, with an acquisition.

           

          In my opinion, if they are on a version of ePO that old, chances are nothing else has been updated, either.

           

          I would suggest deploying a brand (spanking) new server (physical or virtual, as per need), with the latest/greatest versions of McAfee software. Then migrate your systems in a controlled manner. This gives you an opportunity to 'do it right' and 'make it yours'.

           

          One (brutal) consideration you'll need to take into account is the deployed software. Certainly, HIPS, EEPC, etc may (and will) complicate matters.

           

          Once complete, :-) - either eWaste the old system, or donate it to a museum of antiquities.... :-)

           

           

          1 of 1 people found this helpful
          • 2. Re: Need to upgrade EPO 4.5
            awnishkumar643

            Thanks  Dutchman39 for your reply..i hope will get a new EPO installed soon with the latest version Thanks again for your valuable reply.

             

            If possible can you please let me know from which minimum version upgrade is possible?

            • 3. Re: Need to upgrade EPO 4.5
              Dutchman39

              Good luck - I think you'll be happy with the solution.

              If you're creating a new ePO system, it doesn't really matter about upgrading. Set it up, establish your software versions and migrate some machines.

               

              Now, you will want to migrate some test clients first, to better understand your process, and what software on teh client gets upgraded in teh process, and how to manage said upgrade.

              Thereafter, I suggest you migrate only a set number of systems, per day, so as to now overwhelm your networking guys with bandwidth alerts (spread them out over a few days/weeks).

              One process I used in the past, was to have the old ePO system export a text file (50 systems), of IP Addresses (I had them sorted by GUID as a pseudo-random sequencer), and then have the NEW system import that list, and deploy agents.

              If you want to upgrade VS at the same time, that's on you, or you can treat that separately, post migration.

               

              Don't be surprised, though, if the ePO 4.5 system has old versions of software (VS, MA, etc) which are no longer supported by 5.3.2.

              • 4. Re: Need to upgrade EPO 4.5
                awnishkumar643

                But what i need to do with all the existing agents installed on all the client machines.

                Do i need to uninstall all the agents  on all the machines or i need to upgrade/replace the agent as old version agents will not support EPO 5.3.2

                • 5. Re: Need to upgrade EPO 4.5
                  Dutchman39

                  If you deploy NEW agents to those machines, the new Agent should replace the old agent. You may have a small percentage {½ of 1%} which may require manual intervention.

                   

                  Generally, if you're going from an older Agent to a new Agent, you should be good.

                  • 6. Re: Need to upgrade EPO 4.5
                    awnishkumar643

                    Thanks Dutchman for your reply... i about to start the deployment.

                    • 7. Re: Need to upgrade EPO 4.5
                      Dutchman39

                      Best wishes for a smooth, and ultimately satisfying deployment.

                      • 8. Re: Need to upgrade EPO 4.5
                        valentin.talpeanu

                        You have in the Install Guide for 5.3.0 release the best logical chart to follow. https://kc.mcafee.com/resources/sites/MCAFEE/content/live/PRODUCT_DOCUMENTATION/ 25000/PD25506/en_US/epo_530_ig_0-00_en-u… 

                        I have done an update from ePO 4.6.6 to 5.1.1 with SQL update and the 5.1.0 Install Guide was not that good as this one. So use it if you choose to do this upgrade.

                        • 9. Re: Need to upgrade EPO 4.5
                          awnishkumar643

                          Thanks Valentin for your reply, but fortunately i installed and configured the new EPO 5.3.6 from the Scratch.

                           

                          Thanks everyone for your comments and suggestions.

                           

                          Regards,

                          Awnish.