4 Replies Latest reply on Sep 12, 2008 8:11 AM by tonyb99

    Patch versions incorrectly reporting

      I am using EPO4 (Patch2) and managing 1400 machines. I currently have an issue where I am pushing out patch 16 for VSE 8 and some of my machines are reporting that they are running patch 15.

      If I modify the install task for a single machine and monitor the agent log, the task starts, runs and then completes with the message "Product running the latest hotfix) but in EPO it is still reported as having 15 installed.

      Any pointers?
        • 1. RE: Patch versions incorrectly reporting
          What agent are you running ?

          If you check the agent logs then I suspect you will see that the machines are running patch 16 but this information isn't being uploaded to ePO.

          From experience i've tried different methods to resolve this. These have been run from ePO and SMS

          The easiest method is to remove the GUID , reboot the system and then run an agent wakeup from EPO

          The other method is to remove the Agent and all the associated files from the C: and reinstall the agent.

          Note Agent 4.0 works better than 3.6, but that is only from my personnal experience.
          • 2. Patch versions incorrectly reporting




            They are a mix of 3.6 and 4.0 - Probably a stupid question, but how would I go about removing the GUID?
            • 3. RE: Patch versions incorrectly reporting
              Run these from command line.

              REG DELETE HKLM\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent /v "Agent GUID" /f

              REG DELETE HKLM\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent /v "MAC Address" /f


              Reboot the machine and do an agent wakeup.
              • 4. RE: Patch versions incorrectly reporting
                tonyb99
                you dont even need to go that far.........

                OPTIONAL (connect via console and disable access protection {as if you have this set to stop processes then you cant stop the next step}
                stop framework service
                regedit to key HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent\AgentGUID and del the value
                restart framework
                restart access protection if you stopped it
                wakeup with full props from server console

                it will now regenerate the GUID

                you dont need a reboot, or even the mac address as this will also regenerate if you kill the guid key