1 Reply Latest reply on Oct 20, 2016 7:05 PM by Jon Scholten

    McAfee Web Gateway blocking localhost

    junderwood

      I didn't find anything right away in the forum so apologize if this has been answered, please direct me to the right place if it has been.

       

      When trying to access localhost:8080 on my laptop I keep getting the "McAfee Web Gateway has blocked...." message.

       

      Why would this block my local machine and how can I get past it?

       

      Here are some details in the message:

      McAfee Web Gateway has blocked your request because you have not been authorized and authorization is required.

       

        User: (192.168.177.18)
         URL: http://localhost:8080/ (127.0.0.1)

       

       

      Thanks in advance

        • 1. Re: McAfee Web Gateway blocking localhost
          Jon Scholten

          Hi Junderwood!

           

          Don't send localhost traffic to the proxy, there is no way that the MWG can route that back for you. If you want instructions on that, google "localhost through proxy" (this is not an attempt at sarcasm, genuinely trying to help). You'll find how to bypass local addresses from hitting the proxy.

           

          When you tell any computer to connect to "localhost" you're basically saying "talk to yourself" (all traffic would stay on your machine). Your proxy settings must be set to ALWAYS use the proxy for everything, so when you send a request for "localhost", instead of "talking to yourself", you're telling the proxy to "talk to yourself" (that actual request goes to the proxy instead of staying on your machine).

           

          The MWG isnt blocking you on purpose, it just would never be able to process that request in the way you want it to.

           

          Best Regards,

          Jon