5 Replies Latest reply on Sep 3, 2008 9:18 AM by Archmage

    Can't deploy McAfee agent 4 to other domains.

      I'm using ePO 4.0.0 (Build 1113), and can deploy McAfee agent 4 to my domain X.
      However, we have some other domains in a separate forest, for which I get the following error when deploying using ePO:

      Failed to authenticate with remote system, system error: The network path was not found.

      When deploying the agents, I am specifying the proper domain name, username, and password for these other domains.

      Any idea how to get the agents to deploy through ePO?
      It would be a hassle to have to install the agents manually on all these systems.

      Mike
        • 1. RE: Can't deploy McAfee agent 4 to other domains.
          From the EPO server can do connect to \\machine\admin$ using the credentials.
          Check your DNS - are you able to resolve the machine name?
          • 2. RE: Can't deploy McAfee agent 4 to other domains.
            From the ePO server I can't do \\machinename\admin$, as I get a windows errors saying can't access \\machinename\admin$.
            However, I can do \\fullyqualifiedmachinename\admin$, as it then prompts me for a username and password.

            If I ping machinename, it says cannot find host, but I can ping fullyqualifiedmachinename.

            This musty mean that when deploying agents, that ePO deploys them to \\machinename, and not to \\fullyqualifiedmachinename.

            Mike
            • 3. RE: Can't deploy McAfee agent 4 to other domains.
              In your DNS search suffix on the machine name sure you have the domain listed. If its not there you will be able to ping fqdn but not machinename (with domain name)
              • 4. RE: Can't deploy McAfee agent 4 to other domains.
                Try configuring DNS forwarders on the DNS server that EPO uses.

                Your correct in that epo uses \\machinename rather than \\fullyqualifiedmachinename\

                Everything you are doing sounds correct.

                I have 4 different domains controlled by 1 EPO server.

                The only suggestion i'd make is having a seperate repository site list for each domain.
                • 5. RE: Can't deploy McAfee agent 4 to other domains.
                  I seem to have resolved the problem by configuring the DNS Suffix search order on my ePO server, using the following steps:

                  You can configure the DNS suffix search order on a Windows system by following these steps:


                  Access the properties of the network interface you wish to configure.
                  Double-click on "Internet Protocol (TCP/IP)."
                  In the Internet Protocol (TCP/IP) Properties dialog box, click the Advanced button.
                  Click the DNS tab in the Advanced TCP/IP Settings dialog box.
                  Click the "Append these DNS suffixes (in order)" radio button.
                  Now click the Add button to add DNS suffixes to the connection.
                  In the TCP/IP Domain Suffix dialog box, enter the name of the first domain name to append to any DNS search (Example: mcpmag.com).
                  Repeat steps 6-7 for each additional domain.
                  When finished, click OK to close the Advanced TCP/IP Settings dialog box.
                  Click OK to close the Internet Protocol (TCP/IP) Properties dialog box.
                  Click OK to close the network connection's Properties dialog box.

                  I can now deploy agents to machines on those domains that I previously couldn't.

                  Thanks for all the responces. Appreciated.