1 2 Previous Next 11 Replies Latest reply on Mar 30, 2010 8:47 AM by bcalamita

    Install Mcafee Agent on Mac OS X

      Hi,

      Any one can successfully install the agent on Mac OS?

      I've followed the install guide but the machine is still not show up in the EPO console.

      Any log can I trace for it ?
      or any one can share your installation experience.

      :(
      EC
        • 1. have
          djjava9
          you made sure that the mac can get to the epo server via ip and the port that its listening on? it works like a charm but you have to follow the directions to the letter.
          • 2. RE: have
            Dvanmeter
            Yeah, Ive gotten one to show up, and it works really sweet. you can access it like windows http://ipaddress:8081, deploy virusscan 8.6.1, etc. But like you I am having some problems getting all of them to check in. One I had the problem that the machine was already in the databse with and old name from a 3.01 agent. Once I deleted the object , the new one showed up no problems. But on some others I am not getting them to check in at all no matter what, even though I can see the process is running on the mac.
            • 3. RE: have
              I'm trying to do the same thing. I have ePO4.0 with Patch 2 installed and I have loaded up the Agent for Mac (4.0) and VirusScan 8.6.1 into my ePO. But I can't get my agents to work. I was trying to deploy a mac agent to my test mac I have but I don;t get an option for it. I only get a Windows agent option. So then I tried just installing the agent right on the mac so I could at least manage it. I went through the install and it completed successfully but then in the readme it said to open the Terminal and run a bunch of commands. I'm really a novice when it comes to mac so I'm sure I didnt do this last step correctly. Can anyone post exactly the steps that need to be done to get the mac agents to work correctly?

              Thanks!!!
              • 4. RE: have
                Dvanmeter
                you need to pull the agent of off your epo server. On EPO 4.0 agent for mac is probably under C:\Program Files\McAfee\ePolicy Orchestrator\DB\Software\Current\EPOAGENT3700MACX\Install\0409

                The file you are looking for is install.sh, that is the MAC agent equivilant to the windows Framepkg.exe. I recommend removing any old agents or antivirus software prior to installing. I usually reboot also after the install.

                FYI, there are several hotfixes for 8.6.1 and you can import them into epo and epo will deploy.

                Also there is only one Mcafee Agent policy for both MAC and Windows and the Mcafee Agent Update task works for Windows and MAC. So far I only the had the problem on one MAC 10.5 system not showing up. I have loaded the agent on 12 other machines and they all worked fine. You do need to remember that the EPO 4.0 agents for Windows and MAC by default give no access to the http://mycomputer:8081 port. If you have it enabled in the policy for any computer ito access this port on the host it may take up to 5 minutes for the policy to kick in the first time and change the ability for you to access the box on 8081
                • 5. RE: have
                  Thanks for the info. I have tried this on another mac in our test environment and still no luck. I did pull the install.sh file from the location you mentioned and ran the following commands which were in the readme file. I also rebooted after the install.

                  - Copy the file install.sh from the repository selected in the previous step to the target Macintosh client(s).
                  - Log on to the target client as “root”.
                  - On the client, open Terminal, then switch to the location to which install.sh was copied.
                  - Run the command: chmod +x install.sh
                  - Run the command: ./install.sh -i

                  Anything else you can think of that maybe you did differently?

                  Thanks
                  • 6. RE: have
                    Actually nevermind it finally just came up! So now I'm trying to push VirusScan 8.6.1 install from ePO I'll let you know how that goes.

                    Thanks!
                    • 7. hmm
                      Dvanmeter
                      what you are doing is pretty close to how I installed it.

                      1. open a terminal and run sudo su, type password
                      2. Drag the Mcafee EPO agent uninstaller scripts into the terminal and execute
                      3. Drag the Mcafee VirusScan and Virex Uninstaller into the terminal and execute
                      4. Drag the install.sh file into the Terminal and execute.
                      5. Once completed Reboot the system and wait approximately 5 minutes for it to show.


                      Im not sure why its not working for you. Is your Mac version under 10.4.6?
                      • 8. RE: hmm
                        Well it looks like its working on 2 out of 3 macs I have tried. I think it doesn't work on mine because I had an older version of the agent so I probably just need to clean it out. I was able to push VirusScan to both of the macs that the agent worked correctly on.

                        Thanks so much for all your help!
                        • 9. RE: hmm
                          Dvanmeter
                          no problem, im pretty impressed with it compared to how it use to be and how it is now, when it works that is :).null I only got 1 now out of 30 that doesnt work
                          1 2 Previous Next