9 Replies Latest reply on Sep 24, 2008 2:36 AM by pbmdk

    help ! .->  product conflict HOSTIPS_7000 will not be installed

      hi there.
      I have problems with pull the installation of hips 7 from the epo server. the status monitor keeps on telling me that product conflict HOSTIPS_7000 will not be installed. and "can't get uninstall command from plugin-area"
      maby it have something to do with an new version from ver. 6 to 7 of hips.

      I tryed to manualy uninstall the mcafee epo client (3.6.0.453) and evertything that have something to do with mcafee. on the client pc.

      I saw that when I install the epo client it copy all the installation folders needed to this directory
      C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\Current

      but it don't copy HOSTIPS_7000 folder.

      If I check another pc that works the folder is there.. I think it have something to do with that.
      Can someone help me out ?
        • 1. msscript log
          20080827121313: DTP04: ScriptEngine: DTP04 Initializing update...
          20080827121313: DTP04: ScriptEngine: DTP04 Verifying catalog.z.
          20080827121313: DTP04: ScriptEngine: DTP04 Replacing file C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\catalog.ztp with C:\Documents and Settings\All Users\Application Data\McAfee\Common Framework\catalog.z
          20080827121313: DTP04: ScriptEngine: DTP04 Extracting catalog.z.
          20080827121313: DTP04: ScriptEngine: DTP04 Loading update configuration from: Catalog.xml
          20080827121314: DTP04: ScriptEngine: DTP04 Can't get uninstall command from plug-in area.
          20080827121314: DTP04: ScriptEngine: DTP04 Can't get uninstall command from plug-in area.
          20080827121314: DTP04: ScriptEngine: DTP04 Can't get uninstall command from plug-in area.
          20080827121314: DTP04: ScriptEngine: DTP04 Checking for software conflicts.
          20080827121314: DTP04: ScriptEngine: DTP04 Product Conflict: HOSTIPS_7000 will not be installed.
          20080827121314: DTP04: ScriptEngine: DTP04 Verifying VSE850Det.McS.
          20080827121314: DTP04: ScriptEngine: DTP04 Verifying VSE850Det.McS.
          20080827121314: DTP04: ScriptEngine: DTP04 Verifying MAS850det.mcs.
          20080827121314: DTP04: ScriptEngine: DTP04 VSEInstalled = TRUE
          20080827121314: DTP04: ScriptEngine: DTP04 MASInstalled = TRUE
          20080827121314: DTP04: ScriptEngine: DTP04 LanguageMatch = TRUE
          20080827121314: DTP04: ScriptEngine: DTP04 bUpgrade = FALSE
          20080827121314: DTP04: ScriptEngine: DTP04 Verifying MAS850det.mcs.
          20080827121314: DTP04: ScriptEngine: DTP04 VSEInstalled = TRUE
          20080827121314: DTP04: ScriptEngine: DTP04 MASInstalled = TRUE
          20080827121314: DTP04: ScriptEngine: DTP04 LanguageMatch = TRUE
          20080827121314: DTP04: ScriptEngine: DTP04 bUpgrade = FALSE
          20080827121314: DTP04: ScriptEngine: DTP04 Update Finished
          20080827121314: DTP04: ScriptEngine: DTP04 Closing the update session.
          • 2. RE: help ! .->  product conflict HOSTIPS_7000 will not be installed
            djjava9
            try removing your current hips package from the repo and check in the latest one.
            • 3. RE: help ! .->  product conflict HOSTIPS_7000 will not be installed
              I tried to check the hips in again on the epo. but a forgot to remove the current first.
              but I dont think it worked.
              i still get the
              Cant get uninstall command from plugin-arera
              • 4. blocking port!. can't communicate with epo server
                after I rechecked checked hips 7 package into epo 3.6.1 server., the clients pull the hips package before the antivirus 8.5.i and hips blokking the port that epo client speak with the epo server on, but there is allready a hips port policy that allows FrameWorkservice to talk with epo server on all port. but I can see in the hips log that it is blogging on some ports. if I disable hips it starts to communicate with epo server.
                have anyone seen this before?:confused:
                • 5. port
                  djjava9
                  is it possible that you are not using the default port of port 80? goto epo server and change your firewall to adaptive mode, then disable hips so it can talk to epo and get new policy, it will reenable hips in adaptive and automatically add a rule to let you see what it needs to communicate to epo, look on the local client.
                  • 6. RE: port
                    I think there gone something wrong when rechecked the hips package.
                    I had a hips policy that allow frameworkservice.exe to communicate on all ports and it is setup to use fingerprint. but that don't work. it works when I change the policy manualy to path. it seems to work. but I have to manualy deaktivate the firewall so it don't block the frameworkservice.exe. and then it can get the epo policy so it work. but in that way I have to go out to all the pc's and manualy deaktivate firewall and get the new policy from the epo server. argh.
                    • 7. RE: port
                      I think there gone something wrong when rechecked the hips package.
                      I had a hips policy that allow frameworkservice.exe to communicate on all ports and it is setup to use fingerprint. but that don't work. it works when I change the policy manualy to path. it seems to work. but I have to manualy deaktivate the firewall so it don't block the frameworkservice.exe. and then it can get the epo policy so it work. but in that way I have to go out to all the pc's and manualy deaktivate firewall and get the new policy from the epo server. argh.
                      • 8. Here's how I fixed this
                        I ran into the exact same problem a while back. What it turned out to be was HIPS 7 wasn't being replicated to my distributed repository. I made a server adjustment and had the test PCs pull HIPS 7 directly from the ePO server vs. the repo and they started pulling down HIPS. They should have failed over to the server, it was set that way, but did not. Since then, I've fixed my repository problem. happy
                        • 9. RE: Here's how I fixed this
                          I have fixed the problem.. I think I have. i downloaded the "client control" and was able to make a bat file that shutsdown hips the with client control. and copys firenetprefs.txt where the policy has allowed frameservice's path / hash to communicate. and that bat file have been distributed to some test pc' yesterday. if everything works well we role it out to production pc's.