2 Replies Latest reply on Aug 24, 2008 6:45 PM by dk1

    EPO issues after moving SQL db from MSDE to SQL Express 2005

      Hi,

      I recently upgraded my EPO server from MSDE 2000 to SQL Express 2005 (with advanced services). We are using EPO 4 patch 2. This is the same physical server, running both the database and EPO.

      I installed the new version of SQL on the server while MSDE was still installed. The new installation had an instance name of SQL Express. This was done mainly because there are additional databases on this server that I would have to migrate as well and I didn't want to take them all down at once.

      I stopped the EPO services, backed up the EPO database, restored it into SQL 2005 express, started the services then went into the http://<eposerver>/core/config page and changed the SQL instance/database and credentials. I have tried using both a domain admin and the sa login for the SQL credentials on this page.

      I can login to the EPO console, and everything seems to work normally. However, it appears that clients are not updating in the Systems tree- I can do a wake agent, or a collect and send props on a PC and it never updates the time/date of last update in the systems tree for that PC. Additionally, it appears all my scheduled tasks no longer work. The repository pull task doesn't run, and if I try to kick it off manually it says that its running, but the next time I look at the task log it says it completed successfully but it hasn't actually done anything. On the dashboards it says that the 5367 dats are available but in my repository it only contains 5365. I have recreated the repository pull task and run it multiple times but it never works.

      I am getting these errors in the log files:
      server.log:
      20080822142831 I #7716 EPOServer Initializing server...
      20080822142831 I #7716 EPOServer Initializing DAL Connection Pool...
      20080822142831 I #7716 usermgr Attempting to add user: <domain>\<admin>
      20080822142831 I #7716 usermgr Current user: SYSTEM
      20080822142831 I #7716 EPOServer DAL Connection Pool Initialized.
      20080822142831 I #7716 usermgr Attempting to add user: <domain>\<admin>
      20080822142831 I #7716 usermgr Current user: SYSTEM
      20080822142901 E #7716 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822142901 E #7716 DAL Meaning = Unspecified error
      20080822142901 E #7716 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822142901 E #7716 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822142923 I #7036 usermgr Attempting to add user: <domain>\<admin>
      20080822142923 I #7036 usermgr Current user: SYSTEM
      20080822142923 I #7036 EPOServer Initializing server...
      20080822142923 I #7036 EPOServer Initializing DAL Connection Pool...
      20080822142923 I #7036 usermgr Attempting to add user: <domain>\<admin>
      20080822142923 I #7036 usermgr Current user: SYSTEM
      20080822142923 I #7036 EPOServer DAL Connection Pool Initialized.
      20080822142923 I #7036 usermgr Attempting to add user: <domain>\<admin>
      20080822142923 I #7036 usermgr Current user: SYSTEM
      20080822142955 E #7036 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822142955 E #7036 DAL Meaning = Unspecified error
      20080822142955 E #7036 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822142955 E #7036 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822143027 E #7036 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822143027 E #7036 DAL Meaning = Unspecified error
      20080822143027 E #7036 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822143027 E #7036 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822143102 E #7036 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822143102 E #7036 DAL Meaning = Unspecified error
      20080822143102 E #7036 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822143102 E #7036 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822143105 E #7036 DAL CConxIndex::CConxIndex - giving up retrying connection.
      20080822143105 E #7036 ServLite FindServerInfo error -1
      20080822143105 E #7036 EPOServer Initialize Licensing Failed.
      20080822143105 E #7036 mod_epo Failed to start naimserv module


      EpoApSvr.log:
      20080822142837 I #2012 EPOJNI Getting license data...
      20080822142905 I #6300 RManJNI Starting RManJNI
      20080822142905 I #6300 usermgr Attempting to add user: <domain>\<admin>
      20080822142905 I #6300 usermgr Current user: SYSTEM
      20080822142905 I #6300 usermgr Attempting to add user: <domain>\<admin>
      20080822142905 I #6300 usermgr Current user: SYSTEM
      20080822142938 E #6300 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822142938 E #6300 DAL Meaning = Unspecified error
      20080822142938 E #6300 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822142938 E #6300 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822143009 E #6300 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822143009 E #6300 DAL Meaning = Unspecified error
      20080822143009 E #6300 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822143009 E #6300 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822143044 E #6300 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822143044 E #6300 DAL Meaning = Unspecified error
      20080822143044 E #6300 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822143044 E #6300 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822143047 E #6300 DAL CConxIndex::CConxIndex - giving up retrying connection.
      20080822143047 E #6300 RManJNI ServerKeyChanged() error retrieving data from EPOServerInfo
      20080822143047 I #6300 usermgr Attempting to add user: <domain>\<admin>
      20080822143047 I #6300 usermgr Current user: SYSTEM
      20080822143047 I #6300 usermgr Attempting to add user: <domain>\<admin>
      20080822143047 I #6300 usermgr Current user: SYSTEM
      20080822143117 E #6300 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822143117 E #6300 DAL Meaning = Unspecified error
      20080822143117 E #6300 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822143117 E #6300 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822143151 E #6300 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822143151 E #6300 DAL Meaning = Unspecified error
      20080822143151 E #6300 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822143151 E #6300 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822143223 E #6300 DAL COM Error :80004005 in CConxIndex::CConxIndex
      20080822143223 E #6300 DAL Meaning = Unspecified error
      20080822143223 E #6300 DAL Source = Microsoft OLE DB Provider for SQL Server
      20080822143223 E #6300 DAL Description = [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.
      20080822143226 E #6300 DAL CConxIndex::CConxIndex - giving up retrying connection.
      20080822143226 E #6300 DAL CConxIndex::Execute: Error 0x80004003
      20080822143226 E #6300 DAL Description: (null)
      20080822143226 E #6300 DAL CommandString: select DeploymentPath from EPOMasterCatalog where DeploymentPath is not NULL and ProductType='Install'
      20080822143226 E #6300 DAL
      20080822143226 E #6300 RManJNI Caught SQL com error Invalid pointer, Statement: select DeploymentPath from EPOMasterCatalog where DeploymentPath is not NULL and ProductType='Install'
      20080822143226 E #6300 RManJNI Initializing agent package failed to get agent package locations, error -2147483640


      So does anybody have any ideas? Is there something I missed during the database migration?

      Thanks