6 Replies Latest reply on Nov 15, 2016 6:22 AM by spederse

    EEDK 9.6.0\ePOSign.exe - System Error

    joshua.dixon

      Here are the steps take to reproduce the issue with EEDK 9.6.0.

       

      My box is Windows 10 Anniversary, but the same steps were also taken on my Win7 box.  Both are x64.

       

      -------------------------------------------------------------------------------- ------------------------------------------------------------------------

      Prerequisites:

      --- Obtain latest EEDK Package from https://community.mcafee.com/docs/DOC-3401

      --- Obtain a copy of the software intended for use with the EEDK package.

       

      Steps:

      1.) Unzip the EEDK package.  Windows systems, you may have to goto the properties for the compressed file and click unblock.

      2.) Create 2 directories in the unzipped directory.  Lets call them "_BuildFolder" and "_Software"

      3.) Extract the EEDK package and place the contents in the "_Software" folder.

      4.) Run EEDK.exe as administrator

      5.) In the EEDK GUI, Click Tools > Options

      6.) In Options, next to "Browse Folder", select browse and navigate to "_BuildFolder".

      7.) Click Save

      8.) At the very top is a section that reads "Select file or folder containing software package files(s):", leave the radial on "File", click "Browse"

      9.) Navigate to the software we are preparing for EPO Deployment.

      10.) Fill out the fields.  This is how the application runs and how its displayed in EPO's master repository.

        Example:

        Product Name (8 Characters) : NOTEPAD1

        Product ID : 2016

        Product Version : 1.0.0.0

        Product Description : Deploys Notepad

        Command to Run : Notepad.exe

        Product Detection Key : HKLM\Software\McAfee\NotePad_Test

        Product Detection Key Value : Notepad

       

        OS Support : Windows (All Versions)

      11.) Click Save

      12.) Click "Build Package.

       

      Error Occurs:

       

      "The program can't start because MSVCP71.dll is missing from your computer.  Try reinstalling the program to fix this problem."

       

       

      Press OK to see the secondary error

       

      "Build Results

      ePOSign Erro:

       

      -------------------------------------------------------------------------------- ------------------------------------------------------------------------

       

      I have tried to replace the ePOSign.exe as this was on version 3.6.0.544.  I found this file on my EPO server and tried it, instead.  Same error.  That version is 5.3.2.156.

       

      The glorious internet seems to have nothing on this.  This have happened to me before, but I dont recall the solution.