0 Replies Latest reply on Sep 21, 2016 10:42 AM by gph12

    Looking for Solution to VirusScan On-Access Scan (OAS) Disabled After Windows Updates

    gph12

      Hello,

       

      We could use some help trying to resolve this problem. It's taking up a lot of our time lately.

       

      Last month we had two Windows 2008 R2 servers where the OAS was disabled. We tried everything to fix it--removing McAfee VirusScan, reinstalling, patching, etc. Nothing worked. Then, magically, it started working again on both systems.

       

      This month, we have three Windows 7 (64 bit) systems with the same problem. On-Access Scan is disabled. We checked the logs.

      • The problem began immediately after Windows updates and a reboot. 
      • The McAfee McShield service wont' start because it depends on the McAfee Validation Trust Protection Service.
      • The McAfee Validation Trust Protection Service starts and immediately stops. It depends on McAfee Inc. mfehidk which does not appear in the list of services and we are trying to determine what to check on that.
      • We removed all of this month's Windows security patches but that did not resolve the issue.
      • We turned off McAfee HIPS and firewall and tried starting the services but that did not resolve the issue.
      • We confirmed the registry settings in this KB are correct: McAfee KnowledgeBase - Error 1920: Service McShield failed to start (when installing VirusScan Enterprise 8.7i)
      • We also referred to this entry but did not find a solution: On Access Scanner:  Why is it disabled?
      • All of our systems have similar if not identical hardware and configurations.

       

      Product Versions:

      • McAfee VirusScan Enterprise 8.8.0700
      • McAfee Agent 4.8.0.1938
      • McAfee Host Intrusion Prevention 8.0.0, build 3800
      • EPO server is: 4.6.0 build 130

       

      We'd appreciate any advice that would help resolve this.

       

      Thanks,

       

      Greg