2 Replies Latest reply on Jun 6, 2017 5:55 PM by atl

    Mac Agent Install - Error Message

    orthompson

      Hello Everyone,

       

      My company started deploying Virusscan Enterprise to a variety of machines recently (Linux, Windows, Mac).  A few of the Mac users have reported seeing the following error message during the installation of the agent:

       

      Jul 27 15:44:24  installer[2965] <Debug>:
      install:didFailWithError:Error Domain=PKInstallErrorDomain Code=112 "An
      error occurred while running scripts from the package “ma.pkg”."
      UserInfo={NSFilePath=./preinstall,
      NSURL=file://localhost/Volumes/MFEMA/ma.pkg#ma.pkg,
      PKInstallPackageIdentifier=comp.nai.cmamac, NSLocalizedDescription=An error
      occurred while running scripts from the package “ma.pkg”.}

      Jul 27 15:44:24  installer[2965] <Error>: Install
      failed: The Installer encountered an error that caused the installation to
      fail. Contact the software manufacturer for assistance.

      installer: The install failed (The
      Installer encountered an error that caused the installation to fail. Contact
      the software manufacturer for assistance.)

      "disk2" unmounted.

      "disk2" ejected.

       

      I've searched high and low for a resolution, but haven't found anything.  Has anyone encountered this...and what did you do to fix it?  The OS they are using is El Capitan 10.11.6, which is supported.  The agent we are trying to install is version 5.0.3.  There are no other anti-virus programs on the machines, and they pass all of the pre-checks.  We run a script to ensure of this prior to the installation.  Again, we only have this problem on some of the machines. 

        • 1. Re: Mac Agent Install - Error Message
          dakotas96

          Did you ever get this figured out by chance? I have the same exact issue.

          • 2. Re: Mac Agent Install - Error Message
            atl

            TRY  THIS   ---

            Log in to a Mac with a local admin account (root) or sudo   -

            Create a directory  in the Application Support folder by executing the following command:

            sudo mkdir -p /Library/Application\ Support/McAfee/
            1. Download the install.sh script from your McAfee ePO Server.
            2. Copy the install.sh script to the directory you created in step 2 by executing the following command:
              sudo cp ~/Downloads***LOCATION YOU DOWNLOADED file to /install.sh /Library/Application\ Support/McAfee/
            3. Modify the permissions on the install.sh script as needed.  
            sudo chmod +x /Library/Application\ Support/McAfee/install.sh

             

             

               Open the directory you created in step 2 by executing the following command:

            sudo open /Library/Application\ Support/McAfee/

            You will have to wait for install  to begin  - depends on how  you have your ePO server configured  .  Or force the install from your ePO server.