4 Replies Latest reply on Aug 4, 2016 8:35 AM by arindamsur

    Redundant ESM database not running

    arindamsur

      Hi,

       

      I have 2 fresh instances ESMs. I want one to act as Primary and other one as redundant.

      So, I marked the secondary as redundant and placed IP of the primary. It showed the message that the services would go down and so it did. Next thing, I configured the primary by marking it as primary and added IP of secondary and clicked OK. After doing this I did not see any message saying that the services will go down. I checked back in the primary, it showed the status as "syncing 0% complete".

      When I ran tail -f /var/log/messages on the redundant ESM, it showed below message.

      unable to get partition list from primary esm.JPG

       

      The database of the redundant is still not running, it has been more than 6 hours, which is weird for a fresh install. resm_status on the redundant esm shows "zero".

      cpservice and dbserver is not running and when I try to do that I get the below message.

      Redundant syncronization is in progress.JPG

       

      Any help to get this sorted out will be appreciated. Thanks.

        • 1. Re: Redundant ESM database not running
          rth67

          Call support to troubleshoot the failure.

          The Primary would not go down until the majority of the data was Rsync'd over to the Redundant - then the services on the Primary would go down while that last bit of information was syncd.

          • 2. Re: Redundant ESM database not running
            syed_rizvi

            There are log files that you can pull that will give you good indication of root cause, however, at this point, I would suggest to call support and let them troubleshoot.

            • 3. Re: Redundant ESM database not running
              rth67

              Basic premise when you setup Primary / Redundant:

               

              The Primary will not copy data for any partitions currently being written to, it will create some sort of marker to let it know where to start once the background copy is done.

              Rsync will then copy over all the rest of the partitions (that were not being actively written to), you will then get prompted in the UI to "Finalize" (there is a finite time frame which this is available - then it goes and starts another Rsync and you have to wait for another "Finalize" prompt).

               

              Once you acknowledge the "Finalize" prompt, that is when the services on your Primary will go down, to allow the remaining partitions to be copied over without any new data being added to the database while the new Rsync is running.

               

              Once all of the data is done copying, the Primary becomes available again.

              • 4. Re: Redundant ESM database not running
                arindamsur

                Thanks everyone.

                 

                My primary ESM was not even reaching the stage to clieck "finalize", had to reach tech support. The below mentioned helped and it got resolved.

                 

                • Removed the secondary esm from primary
                • Moved the sync file from /usr/local/ess/tmp to /temp
                • Configured the primary with secondary ESM IP
                • Sync started and completed without any issues
                2 of 2 people found this helpful