3 Replies Latest reply on Jul 26, 2016 3:07 PM by jasonpr

    Linux - Failure to install Products mainly VSE 1.9.2

    jasonpr

      Hello All,

       

      I have a Red Hat/Cent OS 6.8 Server and I have McAfee Agent 5.0.2.132 installed fine or so it seems.  The problem I am having is that I cannot get VSE 1.9.2 to install (remotely) from the EPO.  I try to run task now and I have also tried it by creating a product Deployment.  I have used the cmdagent to check to check in but VSE never installs.  So what am I missing?

        • 1. Re: Linux - Failure to install Products mainly VSE 1.9.2
          tlange

          I know that "officially" our kb says 6.8 isn't supported but that is only because we are still testing it.  i've already installed it on a rhel 6.8 server so it will run on that version.

          that said,

          this is either an issue with a missing package on the linux server or the agent is having a problem launching the install.  to figure out which, do the following

           

          on the linux server copy over the vsel install files to a tmp location

          McAfeeVSEForLinux-1.9.2.29197-installer

          McAfeeVSEForLinux-1.9.2.29197.noarch.tar.gz

          kernel-module-source.tar.gz


          open terminal session from that folder and run

          /bin/bash -x  ./McAfeeVSEForLinux-1.9.2.29197-installer --epodeployment


          this simulates the epo install.  it will produce an output on the console of all the commands being run.  if it finishes then the issue you are having is with the agent.  if it errors you will be able to see at what point and what command was run when the error occurred.


          for the agent side you can run the deployment task and when if fails grab the mcscript log from the /var/McAfee/agent/logs folder and either post it or send it to me.

          • 2. Re: Linux - Failure to install Products mainly VSE 1.9.2
            jasonpr

            Ok ran the commands and it completed.  On the Linux system it shows under Products the Agent 5.0.2.132 and LYNXSHLD1920.  On the other hand in System Properties it just shows the McAfee Agent 5.0.2.132 as the only Installed Products.

             

            I looked at the mcscript log and I'm not sure if it completed successfully or not by looking at the log.  Regretfully I cannot send a logs from this system but I'm willing to send parts if you tell what to look for.

             

            Thank You,

            Jason

            • 3. Re: Linux - Failure to install Products mainly VSE 1.9.2
              jasonpr

              Well it appears that both VSEL and HIPs will not deploy as products and need manual installation.  Policy Auditor and other products deploy from the EPO fine.