1 2 Previous Next 16 Replies Latest reply on Jun 7, 2011 1:46 PM by brentil

    I can't reinstall ePO 4.0 after it went down!

      I have upgraded ePO 3.6.1 to 4.0 and it was running well until a windows update occurred and system restarted. The ePO service didn't started, I manually put it up, but in the login page at the console there was a warning of repository error.

      Since that I could not make anything in ePO that made changes to the repository. I uninstalled ePO 4.0 and it gave and error at the beginning of the new installation:

      "Setup has encountered the error:
      FAILURE: In UseDLL to load the following DLL with return code [-1]: [C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{B25DA85E-8177-43ED-B152-4B26D6B8BF85}\Comm onSetup.DLL]

      For more information, search for the error in the EPO400-Install-MSI.LOG file, located in the logged-on user’s Temp directory."

      In the end of that file it mentions the error:

      "1: setNaiLicense return Code = [0]
      1: User accepted the license.
      1: Ending SdePOLicense
      1: Starting SdePOEndOfLifeProdWarning
      1: Ending SdePOEndOfLifeProdWarning
      1: Verifying that the Install directory is valid.
      1: Loading the following DLL for Use: [C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{85FB5FF3-46BE-4A6A-A4AA-079E8469AD32}\Comm onSetup.DLL]
      1: Setting the current directory to [C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{85FB5FF3-46BE-4A6A-A4AA-079E8469AD32}].
      1: FAILURE: In UseDLL to load the following DLL with return code [-1]: [C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\{85FB5FF3-46BE-4A6A-A4AA-079E8469AD32}\Comm onSetup.DLL]
      1: Stopping the services so that the logs can be gathered.
      1: Service [] did not exist so skip stopping of service.
      1: Service [] did not exist so skip stopping of service.
      1: Service [] did not exist so skip stopping of service.
      MSI (c) (E0:74) [14:46:09:250]: Destroying RemoteAPI object.
      MSI (c) (E0:68) [14:46:09:250]: Custom Action Manager thread ending.
      === Verbose logging stopped: 04-04-2008 14:46:09 ==="


      Then I installed ePO 3.6.1 and it works fine, but when I tried to upgrade it, like the first time, but I got the same error!

      I've tried to install it over and over cleaning the server as much as I can, but it staid the same.

      And worst, a few days ago I found that another server of another location of my company is with the same problem, but I still have the ePO 4.0 installed and it's not working the service! Witch means that the problem is not from the machine itself, as the machines and their configurations are different!

      Can anyone help?

      Thanks
        • 1. RE: I can't reinstall ePO 4.0 after it went down!
          I'm having the same issue. I've a case open with McAfee for close to 3 weeks with no solution as of yet. If anyone can come up with something it would be considerably helpful
          • 2. Possible solution
            I was also perplexed by this, and had an open case. However, I figured out the cause (for my situation) myself. I did receive the EXACT same error messages that electronPT was getting on a net-new install. Also our existing EPO 4.0 install had repository access failures. In my case it was due to a conention between ENCRYPTION software:

            I believe I have resolved the issue with the EPO v4.0 server. There was some sort of "contention" between the cryptographic functions controlled by EPO and those controlled by Dameware's FIPS-compliant processes. The following Dameware technical article identifies the files involved.
            http://www.dameware.com/support/kb/article.aspx?ID=100000

            I determined the dependency by noting that some of those Dameware FIPS-associated files were in use unless I stopped the McAfee services.

            Also I noticed in the McAfee install folder there is a file named cryptocme2.dll - which matches a file used by Dameware's FIPS Mode - so I think the issue may be related to versioning with this DLL.

            Once I manually uninstalled the FIPS-compliant files related to the Dameware install I ten rebooted my EPO server and all was well...

            I also had the situation where the account trying to authenticate to SQL 2005 Express kept getting locked out. I believe this is because the encrypted password was "mangled" due to the differing (but identically named!!!!) crypto functions between Dameware and McAfee.

            It was an interesting discovery to day the least! So look for duplicates of: cryptocme2.dll - Dameware puts them in Windows\System32 whereas McAfee puts them under Program Files\McAfee - so due to path order, the Dameware version was being used preferentially, which EPO 4.0 did not like! LOL!

            This Dameware FIPS crypto component removal cleaned up ALL my McAfee problems - both on a fresh install attempt (on a different server), and repository connection/authentication problems on an existing EPO 4.0 installation. It's like the problem never existed now! I just use RDP instead of Dameware to remote control my EPO 4.0 servers now - although I could probably continue to use Dameware if I avoid installation of the FIPS components in the latestst downloadable version from www.dameware.com

            Hope this information helps!
            • 3. By the way....
              I sent this info to McAfee for the open case I had. So hopefully this issue (cryptographic algorithm contention) will be added to their knowledgebase as a possible solution to this error.
              • 4. Perfect...
                That worked for me as well. Thanks Gittro for the post.
                • 5. RE: Perfect...
                  Problem solved! Thanks gittro for the information!

                  It was exactly that file "cryptocme2.dll" that causes the error. It needs to be deleted so the installation works. In a remote server I actually used Dameware to control the server and run the installation, and it worked fine.

                  I don't understand exactly what caused the issue, but just in case I stop the Dameware service on disconnect.

                  Thanks! happy
                  • 6. EPO won't install after going down
                    Gitto,

                    thanks for the help.

                    I have been battling this for two days.

                    I'm glad I looked in the forums.

                    Thanks again!!
                    • 7. RE: EPO won't install after going down
                      Thanks gittro, works fine for me now too! Dameware again was the problem.
                      • 8. Tahnk You
                        Tahnk You so much, this worked great for us too.
                        • 9. RE: Tahnk You
                          Thanks Mate, You are Great !!!!!!!!!!!

                          I was scrathing my head for a woraround for this error

                          It did worked for me
                          1 2 Previous Next