2 Replies Latest reply on Mar 11, 2016 1:27 PM by squonk_109

    Invalid EPO Server Task "Conduit Platform Health Check"

    squonk_109

      Hello all, I found this problem in production and I was able to simulate it on a lab VM (EPO 5.3.1).

      I checked in a package by mistake "File and Removable Media Protection 5.0". When I removed it, an EPO server task that was created became invalid, Conduit Platform Health Check (see screen shot below).

      I tried to check it back in and disable the EPO Server task before deleting the product, but it still switches to an invalid state when I remove the package.

      With the product checked in, it won't let me delete the task either. The Task shows as below.

       

      Failed Workaround

      - Perform a Application and SQL backup (VM ware snapshot in my case)

      - Stop EPO application services

      - Edit the table "dbo.OrionSchedulerTaskMT"

      - Delete the invalid server task ID

      - Restart EPO services

      - Check Server Task Logs screen

      The above steps broke other Server Tasks, forcing some to also be invalid. So don't do this

       

      Before I open a case, I wanted to check if anyone has had experience with this or other invalid EPO server tasks and found a solution.

       

      Thanks very much.

        • 1. Re: Invalid EPO Server Task "Conduit Platform Health Check"
          squonk_109

          FYI I have opened a case on this issue, SR# 4-13531057973.

          It may take some time but I will advise

          • 2. Re: Invalid EPO Server Task "Conduit Platform Health Check"
            squonk_109

            Hi all, after a couple of calls with support, and a MER, we made progress. It is also present in EPO 5.3.0. McAfee support was also able to re-created the problem.

            The problem with be passed on to the FRP support team but there is a workaround to get rid of the orphaned invalid server task.

             

            I made a mistake using SQL management studio. When you right click and delete a line, it leaves an empty line. I believe this will mess up the Task IDs. (Need to work on my SQL skills ).

            Inside the EPO extension package is an uninstall.sql script. C:\McAfeeFRP5_0\Extension\FRP-extension-5.0.1.136\sql\uninstall.sql

            We tried that but it also messed up other server tasks (some other tasks become invalid) recovery from VM snapshot again.

             

            The proper way was to create a query that viewed the server tasks and then a DELETE statement. After backups, when ran a SQL query to list the task and then delete it.

             

            Since every situation could be a little different, I don't want to just paste the SQL query. I suggest you contact support if you have this issue. You can quote SR# 4-13531057973.

            If this becomes a common problem McAfee can write up a KB.


            Thanks