1 2 Previous Next 12 Replies Latest reply on Feb 8, 2017 5:22 PM by catdaddy

    Galaxy Tab can't join

    tussockland

      I installed Safe Family on my PC, then installed it on my Android Galaxy Tablet.

      Once installed and started 'Connect-to-our-family' button gives following error:

      "Something went wrong, Sorry about that. Want to try again?"

       

      So i can't try this App until it installs on a galaxy tab 10.1"

        • 1. Re: Galaxy Tab can't join
          catdaddy

          tussockland,

                             Until someone with more knowledge/expertize picks up this thread, you can contact Technical Support (Free)   Services and Support for Home and Office

           

                             It seems that you followed the proper steps thus far, by installing it on your Windows PC/Device first.. I recall reading a thread where possibly temporarily (Disabling) Access Protection and attempting to worked? However don't quote me on that, hence best to contact Technical Support to make certain.

           

          All the Best,

          CD

          • 2. Re: Galaxy Tab can't join
            exbrit

            Just a question, when you installed the software, the first thing it would have asked would have been to share your location, did you allow that and any other requests it made?

            Try restarting the device to see if it then works.

            If not Mobile Technical Support is your best bet.

            Contact Support

            • 3. Re: Galaxy Tab can't join
              tussockland

              No, it never asked for anything. It didn't get that far. It didn't install fully yet, stuck on the setup. I can't even uninstall to try again.

              I'm now opening a new post to find out how to uninstall...

               

              1/2 the Android users feedback are disappointed in this app, I expected more from Intel/McAfee!

              (There isn't even a map showing on my PC where there should be one.)

              • 4. Re: Galaxy Tab can't join
                tussockland

                Restarted multiple times, Still no go.

                I found to un-install you must first go settings, security, device admin, and disable safe family.

                Un-installed, restarted...

                Then I re-installed, but still getting same errors...

                • 5. Re: Galaxy Tab can't join
                  exbrit

                  Sorry about that.  I don't use the application so was only suggesting things I found through searching for answers. 

                  Either try contacting support as I suggested or wait and one tech will eventually spot this and help.

                  • 6. Re: Galaxy Tab can't join
                    catdaddy

                    As Colleague Ex_ Brit stated, seems like a call is in order to Technical Support. Or if you choose to wait, I have contacted someone from Technical Support on your behalf. Being the Weekend and their Geographical location, will determine how soon they  respond.

                     

                    Regards,

                    CD

                    • 7. Re: Galaxy Tab can't join
                      catdaddy

                      tussockland,

                                        I might add also, this is a 'Peer to Peer' Community. We as Moderators are Consumers/Users same as you. We do our very best to offer a solution from our personal experience. Should it be the case our suggestions/advice do not resolve your issue.

                       

                                           The next objective is to point you in the proper direction to get your issue resolved.

                       

                      All the very Best,

                      CD

                      • 8. Re: Galaxy Tab can't join
                        tussockland

                        Thank you for your replies :-)

                        I dread contacting them directly, because of different country time zones and expense of phone calls etc ( i live in New Zealand).

                        I actually thought this was the place to get support/answers, but will go direct if staff don't look over these forums and there ends up being no progress.

                         

                        If they can just test someones galaxy tablet to see if it works locally might be a start.

                        I know they can't test every device, but a samsung galaxy must be one of the most used tablets out there.

                         

                        Seems this software is fairly new, and not many are testing it (looking at the small forum).

                        And even the App store feedback from many people say main features do not work (time restrictions, blocking sites...) & with a low rating of 3.1!

                         

                        = I'm still keen to test it to see if it's improved :-)

                        • 9. Re: Galaxy Tab can't join
                          Peacekeeper

                          Call from Aussie free so NZ should also be  You fill out the support form and at the end they give you a number to call. 

                          1 2 Previous Next