7 Replies Latest reply on Dec 28, 2015 5:52 PM by astor

    Real-Time scanning would not stay on until the new update was installed

    astor

      I was experiencing a weird problem today.  Each time I rebooted (since today) and open McAfee SecurityCenter I see the message "Your Real-Time Scanning is starting up".  After a while it gives up and says "Your computer is at risk. Real-Time Scanning is Off.  I ran the Technician tool and it picked up no problems. I'm using version 14.0.5120.  I check for updates and it appears it has installed something new but not sure if it succeeded as the version number hasn't changed - could have been just a signature update.  It says something was installed.  I rebooted the PC and the same problem arises.  I do another manual check for updates, and again it installs something.  Version number hasn't changed but the real-time scanning is now operational.  I reboot the PC again to make sure, and the problem comes back - real-time scanning is turned off and repeated attempts to start it manually fail.  I check for updates again and the same thing happens again. I repeated the whole cycle 4 or 5 times (lost count).  Sometimes it would also warn me the firewall is not turned on.  One more attempt and this time it has installed a new version - 6120. Real-time scanning is now operational.  I reboot to make sure and now everything is fine.  I check for updates one more time and it says I'm up-to-date (as expected). I do not know what the hell was going on but for a while I was concerned. I hope it's all now OK.  Will find out tomorrow when I turn my PC back on.  I did install new updates for Windows 7 (Dell PC) over a week ago but didn't have the McAfee problem until today.  A new version of Firefox was also installed 5 days ago, but again it was all fine until today.  Haven't installed anything else for a long time. The only other thing I did differently on the last attempt that worked is I logged in as Administrator.  My normal account does not have admin privs (for security reasons).  Previously I never had a need to do that - all previous updates appeared to work find via my normal account.  Doesn't explain why real-time scanning was temperamental.   It's as though McAfee knew a new version was available and because it wasn't installed it refused to work properly with the previous release.  Perhaps the previous attempts to install the update corrupted something.  Any ideas?