3 Replies Latest reply on Dec 23, 2015 1:35 PM by andrep1

    Failed to connect to the Software Catalog server -- 403 on epo.mcafee.com

    christian.c.oconnor

      Having trouble with using the Software Manager.. getting the error "The product catalog has not been downloaded yet". Running Server Task manually for Download Software Product List, It fails..

       

      12/21/15 1:13:48 PM  Started: Download Software Product List 

      12/21/15 1:13:48 PM  Started: Update Product Compatibility List Subtask 

      12/21/15 1:13:53 PM  Failed: Update Product Compatibility List Subtask (No updates to the list of compatible products occurred. Enforcement of existing list continues.) 

      12/21/15 1:13:53 PM  Downloading file e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\trial_products_list.xml.tmp. 

      12/21/15 1:13:53 PM  Downloading file e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\licensed_products_list.xml.tmp. 

      12/21/15 1:13:55 PM  Failed to download file e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\trial_products_list.xml.tmp. 

      12/21/15 1:13:55 PM  Failed to download file e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\licensed_products_list.xml.tmp. 

      12/21/15 1:13:55 PM  Failed to connect to the Software Catalog server. 

      12/21/15 1:13:55 PM  Completed: Download Software Product List (Failed to download the products list due to "Failed to connect to the Software Catalog server.")

      =====================

      Looking in the log I see...

       

      20151221131348 I #01324 DOWNLOAD_JNI Downloading file: e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\ProductCompatibilityList.xml.tmp.

      20151221131350 I #01324 MCUPLOAD Connecting to server epo.mcafee.com through proxy server <############>:8080.

      20151221131350 E #01324 MCUPLOAD SecureHttp.cpp(1449): Unexpected HTTP status 403

      20151221131350 I #01324 DOWNLOAD_JNI Finished downloading file: e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\ProductCompatibilityList.xml.tmp (0 bytes).

      20151221131350 I #06636 DOWNLOAD_JNI Downloading file: e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\ProductCompatibilityList.xml.tmp.

      20151221131353 I #06636 MCUPLOAD Connecting to server epo.mcafee.com through proxy server <############>:8080.

      20151221131353 E #06636 MCUPLOAD SecureHttp.cpp(1449): Unexpected HTTP status 403

      20151221131353 I #06636 DOWNLOAD_JNI Finished downloading file: e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\ProductCompatibilityList.xml.tmp (0 bytes).

      20151221131353 I #06780 DOWNLOAD_JNI Downloading file: e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\trial_products_list.xml.tmp.

      20151221131353 I #00308 DOWNLOAD_JNI Downloading file: e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\licensed_products_list.xml.tmp.

      20151221131355 I #00308 MCUPLOAD Connecting to server epo.mcafee.com through proxy server <############>:8080.

      20151221131355 I #06780 MCUPLOAD Connecting to server epo.mcafee.com through proxy server <############>:8080.

      20151221131355 E #00308 MCUPLOAD SecureHttp.cpp(1449): Unexpected HTTP status 403

      20151221131355 I #00308 DOWNLOAD_JNI Finished downloading file: e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\licensed_products_list.xml.tmp (0 bytes).

      20151221131355 E #06780 MCUPLOAD SecureHttp.cpp(1449): Unexpected HTTP status 403

      20151221131355 I #06780 DOWNLOAD_JNI Finished downloading file: e:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\trial_products_list.xml.tmp (0 bytes).

      ====================

      We do go through a proxy, but not really seeing any issues there. I tested accessing https://epo.mcafee.com with Internet Explorer and get a server error

      ------------------

      403 - Forbidden: Access is denied.

      You do not have permission to view this directory or page using the credentials that you supplied.

       

      I think tried "https://epo.mcafee.com/ProductCompatibilityList.xml". And this work fine but seems like ePO is having issues doing this and I get the 403 error still.

       

      I have also tested this URL with my home internet, iPad, and anything not tied to my work network and get the same result. Is there a problem with the site or something im not doing? I seem to be the only one having this problem. I have googled this issue and noticed one other person who reported this issue and no resolution. All the required Certs are in place and working as per other posts I have read.

       

      -Thanks in advance!