1 2 Previous Next 10 Replies Latest reply on Jan 28, 2016 1:14 AM by catdaddy

    Install hangs while checking software, can't contact support

    cragsdell

      Can't install or contact support. While trying to install the McAfee MultiAccess software provided by Cox as part of their online security suite, the install hangs repeatedly while checking for incompatible software. It has run for over an hour now with no joy, and this is the third time I've tried...

       

      Then when I tried to contact tech support to set up a chat or a phone call (tried both...), the form won't submit. I have filled all required fields, click submit, and nothing happens. I then tried to submit a form to the Total Satisfaction Team, and same result... the form won't submit. Click the Submit button, and nothing happens. I've tried using two different Mac laptops AND an iPad AND an iPhone, and the forms won't submit on any of them. Is there any way to contact Tech Support other than through these forms? Can I send an email asking for a return call?

        1 2 Previous Next