2 Replies Latest reply on Feb 28, 2008 4:32 AM by gerryrigney

    Cant access MSDE via osql to reduce DB size

      Hi All

      I've got a few problems with ePO (3.6.1 with patch 3 installed)

      I think its down to the MSDE being full, its currently 1.9GB but there's lots of errors in the eventparser log:

      DAL error: Could not allocate space for object 'Events_VSEBehaviourBlock' in database 'ePO_W2KSDBL3' because the 'PRIMARY' filegroup is full.

      I'm now trying to run a few OSQL commands (taken from mcafee support) but it won't let me log onto the DB.

      C:\>osql -E -d ePO_W2KSDBL3
      [Shared Memory]SQL Server does not exist or access denied.
      [Shared Memory]ConnectionOpen (Connect()).


      I've tried varing changes of caps, various user names and passwords (including SA) but it keeps returning the errors. I've also tried both with the various Mcafee services running and not running. I don't have access to the sql enterprise manager.

      Anyone any ideas how I can gain access to the DB to reduce the file size?

      TIA
      gerryR