7 Replies Latest reply on Feb 19, 2008 5:45 AM by tonyb99

    viruscan8600 plugin missing in registry?

    kjhurni
      I've got a bunch of machines with EPO 3.6 (latest agent) on them.

      but the viruscan 8.5i stuff isn't working properly (meaning it's not updating, running tasks, etc)

      This shows up in the log file:

      20080124081657 I #228 Manage DoesSoftwareExists SoftwareID=VIRUSCAN8600
      20080124081657 W #228 Sched Plugin checking: error -1011, SoftwareID = VIRUSCAN8600

      I checked the registry and I'm missing the viruscan8600 key

      I've reinstalled the framepkg a few times, to no avail.

      Do I need to reinstall VSE 8.5i to get it to re-create the keys?
        • 1. RE: viruscan8600 plugin missing in registry?
          You mean "Application Plugins" for the agent in the registry?

          If I'm not mistaken, this comes from your ePO server. Is VirusScan 8.5 available as managed product? Normally this is done by injecting the according NAP file into the ePO server. This will allow you to define policies etc.
          • 2. RE: viruscan8600 plugin missing in registry?
            kjhurni
            Yes, that is correct:

            VSE 8.5i is in the EPO server and other machines work fine.

            I just have a few that aren't working properly.

            So the EPO agent is supposed to populate the registry keys when it talks to the EPO server?

            The machines in question are definitely talking to the EPO Server as they show up with "last contact", but it also shows both 8.0 and 8.5i being installed

            But neither viruscan8000 nor viruscan86000 registry keys are present.

            ??
            • 3. RE: viruscan8600 plugin missing in registry?
              If you see both VS 8.0 & 8.5 listed when you look at the properties of the node, then you certainly have an issue there.

              1. Make sure that the data in ePO is up-to-date by forcing Agent-Server communication, I've had the thing during upgrades sometimes.
              2. The upgrade of 8.0 to 8.5 was done how? If not done properly, there could be a trace somewhere causing both products to show up in the console. I had the issue in the past with Alert Manager. Solution: uninstall, clean registry & files/folders, install product properly.

              I must admit I'm not 100% sure about this and hopefully a senior member will take a look at this post to either confirm or correct the contents.
              • 4. RE: viruscan8600 plugin missing in registry?
                kjhurni
                Thanks.

                I've tried the agent to server communication, and that doesn't reinstall the plugins.

                The Upgrade was done via the MSI file (it did install okay, just that it's not getting the settings)

                I guess the ultimate question is:

                Which "thing" is responsible for creating those registry keys in the plugins?

                EPO agent?

                In which case, I'm curious as to why installing it again doesn't put them back?
                • 5. Me too
                  I also have this problem but with VSE8.0i

                  Most machines are reporting correctly but certain machines are showing as unprotected because VirusScan properties are not showing within ePO.

                  I also looked at the registry and found the plugin flag was set incorrectly.

                  \\HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Application Plugins\VIRUSCAN8000

                  Plugin Flag key was set to either 7 or 8 0x0000000 (x)

                  After looking at a working machine, i changed this to 0 0x0000000 (0)

                  Performed an agent wakeup - VirusScan Properties appeared within ePO.

                  Not sure this answers your question but hope it gives you an idea
                  • 6. update
                    I just tried changing the registry value on a specific machine, performed a wakeup - did not work.

                    Had to stop and start the framework service on the machine before performing a wakeup using ePO and then the properties populated

                    Hope this helps
                    • 7. RE: update
                      tonyb99
                      The easiest and quickest way of resolving this is to just drop the relevant machines into an uninstall and then an install group for VSE policies and let them go back from scratch.

                      I've had the issue before with VSE 8.0 (when installing patch 13) and then again with VSE 8.5 when installing patch 4. Its a pain but I think some of the problems with the patches and the registry were addressed in the CMA patch 3 just released