3 Replies Latest reply on Sep 11, 2015 11:06 AM by jhall2

    EPO 4.6/MDE 7.1.1 continues to show server as "Upgradable"

    gldnju

      I have a Windows 2008 R2 HP G8.  I migrated this server from MEE to MDE 7.1.1.  Usually have the upgrades, the system shows as "upgradable".  If you reboot the system 1-2 times, it will show in EPO as "Active".  This particular server still shows up as "upgradable".  The System Status shows the following error:  EE120002 - Error abandoning activation, EE120002 - Early activation error. 

       

      The server has 2 drive arrays.

           1. MBR RAID 1 (fully encrypted)

           2. GPT RAID 5 - 3TB+ (not encrypted)

       

      Can anyone tell me why the 2 array won't encrypt?

       

      Thanks

        • 1. Re: EPO 4.6/MDE 7.1.1 continues to show server as "Upgradable"
          jhall2

          If possible, please post the MfeEpe.log.

          • 2. Re: EPO 4.6/MDE 7.1.1 continues to show server as "Upgradable"
            gldnju
            2015-09-09 08:10:14,314 INFOStatusService                    Creating Preboot File System (PBFS)
            2015-09-09 08:10:14,345 INFOPcSystem                         Beginning activation. Current status is upgradable (major).
            2015-09-09 08:10:14,345 INFOPcSystem                         Abandoning activation
            2015-09-09 08:10:14,376 ERROR   PcSystem                         Error abandoning activation: [0xEE120002]
            2015-09-09 08:10:14,376 ERROR   PcSystem                         Early activation error: [0xEE120002]
            2015-09-09 08:10:14,376 ERROR   StatusService                    Preboot File System (PBFS) creation failed
            2015-09-09 08:10:14,376 WARNING MfeEpePcEncryptionProviderPlugin ..\..\..\Src\EpeGenActivationHandler.cpp:

             

            EPE_gen_activation_handler::send_activate_exception: 932: [0xEE120002]

            2015-09-09 08:10:14,376 WARNING MfeEpeCoreEncryptionPlugin       receive_from_service_first_message_of_type(MfeEpeEncryptionServiceClient, class

             

            ns1__ESActivateEncryptionAck) wrong message received:

            <?xml version="1.0" encoding="UTF-8"?><MfeEpeMessageList xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"xmlns:SOAP-

             

            ENC="http://schemas.xmlsoap.org/soap/encoding/"xmlns:xsi="http://www.w3.org/2001/XMLSchema-

             

            instance"xmlns:xsd="http://www.w3.org/2001/XMLSchema"xmlns:ns1=""xsi:type="ns1:MfeEpeMessageList"><element xsi:type="ns1:ESActivateEncryptionExc">

               <sendTo xsi:type="ns1:MfeEpeAddress" serviceUUID="xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx" serviceName="MfeEpeEncryptionServiceClient"></sendTo>
               <from xsi:type="ns1:MfeEpeAddress" serviceUUID="xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx" serviceName="MfeEpeEncryptionService"></from>
               <errorId>-300810238</errorId>
               <message>[0xEE120002] </message>

                </element></MfeEpeMessageList>

            2015-09-09 08:10:14,376 ERROR   EpoPlugin                        userHandler: failed to process batched user data response: [0xEE120002] [0xEE120002]
            2015-09-09 08:10:14,376 ERROR   StatusService                    Failed to process a batch of user data received
            2015-09-09 08:10:14,376 INFOEpoState                         == End of policy enforcement ==
            2015-09-09 08:10:14,376 INFOStatusService                    Policy enforcement has completed
            2015-09-09 08:10:14,392 INFOPcSystem                         Abandoning activation
            2015-09-09 08:10:14,408 ERROR   PcSystem                         Error abandoning activation: [0xEE120002]
            2015-09-09 08:10:14,408 ERROR   MfeEpePcEncryptionProviderPlugin [0xEE120002]
            2015-09-09 09:35:33,000 INFOEpoPlugin                        enforcePolicy: No policy enforcement required (nothing has changed), waiting until

             

            next ASCI.

            2015-09-09 10:28:36,503 INFODRIVER                           Session notification: EPEPC_DRIVER_SESSION_REMOTE_CONNECT
            2015-09-09 10:28:45,769 INFODRIVER                           Session notification: EPEPC_DRIVER_SESSION_LOGON
            2015-09-09 10:28:57,547 INFOEpoPlugin                        enforcePolicy: new policy store created (session 1440747171).
            2015-09-09 10:28:58,748 INFOEpoPlugin                        enforcePolicy: Waiting for OptIn users (i.e. non-default UBP users) before enforcing

             

            policy.

            2015-09-09 10:28:58,764 INFOEpoState                         == Start of policy enforcement ==
            2015-09-09 10:28:58,764 INFOStatusService                    Policy enforcement has started
            2015-09-09 10:28:58,764 INFOEpoPlugin                        enforceUserPolicy: Dispatching enforce policy event.
            2015-09-09 10:28:58,764 INFOEpoPlugin                        policyHandler: handling EnforcePolicy event
            2015-09-09 10:28:58,795 INFOEpoPlugin                        userHandler: handling AddLocalDomainUsers event
            2015-09-09 10:28:58,811 INFOEpoPlugin                        userHandler: handling AddLocalDomainUsers response
            2015-09-09 10:28:58,826 INFOEpoPlugin                        epoAudit: dispatching audits to AgentHandler
            2015-09-09 10:28:58,842 INFOEpoPlugin                        userHandler: System is upgradeable
            2015-09-09 10:28:58,842 INFOEpoPlugin                        userHandler: dispatching GetAllUsers event to AgentHandler
            2015-09-09 10:28:58,842 INFOEpoPlugin                        userHandler: Note, press Send Events button in McAfee Agent to hasten delivery (see

             

            KB71865).

            2015-09-09 10:28:58,857 INFOStatusService                    Creating Event to request data for assigned users
            2015-09-09 10:29:09,980 INFOEpoPlugin                        enforcePolicy: Policy Enforcement is already in progress, skipping this one.
            2015-09-09 10:29:10,027 INFOEpoPlugin                        enforcePolicy: Policy Enforcement is already in progress, skipping this one.
            2015-09-09 10:29:20,760 INFOEpoPlugin                        collectProperties: dispatching disk list to AgentHandler
            2015-09-09 10:29:20,791 INFOEpoPlugin                        epoAudit: dispatching audits to AgentHandler
            2015-09-09 10:29:45,111 INFOEpoPlugin                        userHandler: handling GetAllUsers response
            2015-09-09 10:29:45,111 INFOStatusService                    Received data for assigned users
            2015-09-09 10:29:45,236 INFOMfeEpeCoreEncryptionPlugin       --- Activation Begins ---
            2015-09-09 10:29:45,236 INFOStatusService                    Activation has started
            2015-09-09 10:29:45,236 INFOStatusService                    Searching available Encryption Providers
            2015-09-09 10:29:45,236 INFOMfeEpeCoreEncryptionPlugin       Size of provider order list in policy is 2
            2015-09-09 10:29:45,236 INFOMfeEpeCoreEncryptionPlugin       Service with UUID xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx has state: Upgradeable
            2015-09-09 10:29:45,236 INFOMfeEpeCoreEncryptionPlugin       Found a preferred provider with UUID xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx with state:

             

            Upgradeable

            2015-09-09 10:29:45,252 INFOMfeEpeCoreEncryptionPlugin       Service with UUID 6477FB57-DCF1-418E-9948-9F32C57B0FA4 has state: Unsupported
            2015-09-09 10:29:45,252 INFOMfeEpeCoreEncryptionPlugin       Final preferred provider with UUID xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx is selected with

             

            state: Upgradeable

            2015-09-09 10:29:45,252 INFOStatusService                    Located the Encryption Provider to use
            2015-09-09 10:29:45,252 INFOStatusService                    Detecting incompatible products
            2015-09-09 10:29:45,517 INFOMfeEpeCoreEncryptionPlugin       CoreEncryptionPlugin: No HW Product matched
            2015-09-09 10:29:45,517 INFOStatusService                    No incompatible products found
            2015-09-09 10:29:45,642 INFOStatusService                    Creating Preboot File System (PBFS)
            2015-09-09 10:29:45,704 INFOPcSystem                         Beginning activation. Current status is upgradable (major).
            2015-09-09 10:29:45,704 INFOPcSystem                         Abandoning activation
            2015-09-09 10:29:45,704 ERROR   PcSystem                         Error abandoning activation: [0xEE120002]
            2015-09-09 10:29:45,704 ERROR   PcSystem                         Early activation error: [0xEE120002]
            2015-09-09 10:29:45,704 ERROR   StatusService                    Preboot File System (PBFS) creation failed
            2015-09-09 10:29:45,704 WARNING MfeEpePcEncryptionProviderPlugin ..\..\..\Src\EpeGenActivationHandler.cpp:

             

            EPE_gen_activation_handler::send_activate_exception: 932: [0xEE120002]

            2015-09-09 10:29:45,704 WARNING MfeEpeCoreEncryptionPlugin       receive_from_service_first_message_of_type(MfeEpeEncryptionServiceClient, class

             

            ns1__ESActivateEncryptionAck) wrong message received:

            <?xml version="1.0" encoding="UTF-8"?><MfeEpeMessageList xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"xmlns:SOAP-

             

            ENC="http://schemas.xmlsoap.org/soap/encoding/"xmlns:xsi="http://www.w3.org/2001/XMLSchema-

             

            instance"xmlns:xsd="http://www.w3.org/2001/XMLSchema"xmlns:ns1=""xsi:type="ns1:MfeEpeMessageList"><element xsi:type="ns1:ESActivateEncryptionExc">

               <sendTo xsi:type="ns1:MfeEpeAddress" serviceUUID="xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx" serviceName="MfeEpeEncryptionServiceClient"></sendTo>
               <from xsi:type="ns1:MfeEpeAddress" serviceUUID="xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx" serviceName="MfeEpeEncryptionService"></from>
               <errorId>-300810238</errorId>
               <message>[0xEE120002] </message>

                </element></MfeEpeMessageList>

            2015-09-09 10:29:45,704 ERROR   EpoPlugin                        userHandler: failed to process batched user data response: [0xEE120002] [0xEE120002]
            2015-09-09 10:29:45,704 ERROR   StatusService                    Failed to process a batch of user data received
            2015-09-09 10:29:45,704 INFOEpoState                         == End of policy enforcement ==
            2015-09-09 10:29:45,704 INFOStatusService                    Policy enforcement has completed
            2015-09-09 10:29:45,720 INFOPcSystem                         Abandoning activation
            2015-09-09 10:29:45,720 ERROR   PcSystem                         Error abandoning activation: [0xEE120002]
            2015-09-09 10:29:45,720 ERROR   MfeEpePcEncryptionProviderPlugin [0xEE120002]
            2015-09-09 10:31:37,633 INFODRIVER                           Session notification: EPEPC_DRIVER_SESSION_LOGOFF
            2015-09-09 10:31:38,023 INFODRIVER                           Session notification: EPEPC_DRIVER_SESSION_REMOTE_DISCONNECT
            2015-09-09 10:31:50,675 INFOEpoPlugin                        enforcePolicy: No policy enforcement required (nothing has changed), waiting until

             

            next ASCI.

            2015-09-09 12:02:02,671 INFOEpoPlugin                        enforcePolicy: No policy enforcement required (nothing has changed), waiting until

             

            next ASCI.

            2015-09-09 13:32:15,555 INFOEpoPlugin                        enforcePolicy: No policy enforcement required (nothing has changed), waiting until

             

            next ASCI.

            • 3. Re: EPO 4.6/MDE 7.1.1 continues to show server as "Upgradable"
              jhall2

              I have seen the issue in the past when attempting to upgrade with a RAID. MDE does not support RAID, although it will likely work. I would suggest decryption and removing EEPC v5 and installing MDE fresh.