3 Replies Latest reply on Oct 8, 2015 11:15 AM by DKB223

    Dell M4800 Laptop Encryption Issues

    DKB223

      I have a user who has a Dell M4800 laptop runnings Windows 7 Enterprise and MDE 7.1.3. All drivers in Windows are up to date as is the BIOS. The laptop is connected to a docking station most of the time when in use. The user states that he gets slow or no response when using a USB keyboard while logging into the PBA screen. He says that he usually has to lift up the screen to use the keyboard on the laptop and to do so means that he has to move his monitors to get at the laptop. Also, the docking station is set up with dual monitors and when docking the laptop, he loses the default monitor. It sounds like the monitor that should be the default, is no longer the default.

       

      The user is my ISSO, so I'd like to try to fix this!  Has anyone seen this behavior with this model or similar Dell model laptops? The 4800 is a relatively new model I believe. The policy that is assigned to the group that this laptop is in has Always enable preboot USB support set. What other information would be helpful for sussing this out?

        • 1. Re: Dell M4800 Laptop Encryption Issues
          jhall2

          I assume the system is set to utilize Legacy BIOS mode not UEFI Native. If so, it is likely the USB bus the docking station is utilizing is USB 3.0 which is not supported with MDE in Legacy BIOS mode as there is no USB 3.0 driver in the preboot environment (KB75650). Although the docking station itself may display the ports as USB 2.0, the hub internal to the dock is likely utilizing hooked into the USB 3.0 bus thus the ports require preboot to access the USB 3.0 bus which will likely fail. It is becoming increasingly common for systems to not USB 2.0 controllers.

           

          If the dock has an eSATA port, try plugging the keyboard into that. The eSATA port is generally a hybrid port that will provide either eSATA or USB 2.0 connectivity. Disabling USB 3.0 on the system may resolve the issue but may result in other unexpected behaviors. The legacy USB option in the BIOS may need to be toggled to either enable or disable the option. There is no correct setting and depending upon the behavior of the system, may need to be turned on or off.

           

          Alternatively, the BIOS can be set to UEFI native and reimaged using a UEFI image or a OEM Windows disk; the standard WIM files most utilize are build for Legacy BIOS and will not function properly with a system in UEFI Native mode. The UEFI preboot supports USB 3.0 as there is no need to have our own USB drivers as the UEFI contains the drivers and preboot can utilize standard protocols to communicate to the devices.

          • 2. Re: Dell M4800 Laptop Encryption Issues
            DKB223

            I will be revisiting this soon. Unfortunately, this user is quite busy and trying to get some time to troubleshoot is not easy. I'll be sure to report back as I can. Thank you for the reply!

            • 3. Re: Dell M4800 Laptop Encryption Issues
              DKB223

              So, I have been testing and disabling the USB 3.0 controller helps with this issue. I can utilize a keyboard and mouse without issue. I've created a test setup like my ISSO's and while I could replicate the behavior with the mouse and keyboard, I've not been successful with the monitors. They've worked as expected. So, next step is see about utilizing UEFI and disabling the legacy BIOS choice.