1 2 Previous Next 16 Replies Latest reply on Sep 4, 2015 3:47 PM by Peacekeeper

    Problem With McAfee Updates

    sssmiley

      Hello, I'm new here so please forgive me if I don't get this right.

      Since the beginning of August, I've been having problems with my McAfee software. I've contacted technical support twice in regards to this issue and both times the rep remotely accessed my PC.

      Let me start by saying that the problem has to do with updating what I believe are updates to virus definitions however I could be wrong.

      Just to let you know, I am running McAfee Security Center SE from AOL Version 14.0, Build 14.0.1029. Basically the software will not automatically update, and I have to manually install the updates. But when I do install an update, I receive the following error message "McAfee cannot update your software, please check your Internet connection" (Refers To TS101370 as found in the FAQ and search section of the McAfee website).

      Of the two sessions with the tech reps, the first one went into the registry and made some changes. After that, things worked fine for a couple of days, then the problem returned. With the second session, the tech rep also went into the registry and also performed some diagnostic tests which according to the rep determined that it's my ISP, and I need to contact them.

      When I contacted my ISP (Verizon), they found no problem. After finding this out, I uninstalled and reinstalled the software. After the software was reinstalled, there was an update. Then the software worked fine for a couple of days. Shortly after that, the problem returned again. So I repeated the process of uninstalling and reinstalling the software a second time and the same thing happened again. I uninstalled and reinstalled a third time, and once again after a couple of days the problem returned.

      I find that the problem occurs after a restart or shutdown of the PC. What I would like to know is there an issue with the update that downloaded shortly after the reinstall, or is there some other unknown issue and in either case what steps do I need to take to resolve this issue once and for all so that the software functions properly.

      If anyone on the forum can help me with this issue in some way, it would be very much appreciated.
      Thanks.

        • 1. Re: Problem With McAfee Updates
          Peter M

          It is a known issue for which a fix is to be issued, when we are not quite sure.

          In the meanwhile disable Access Protection and updates should then work.

          Open the user interface and click Navigation in the main window at the right.

          Then click General Settings and Alerts

          Click Access Protection

          Uncheck Use Access Protection and click Apply.

           

          Don't worry you should be OK.

          • 2. Re: Problem With McAfee Updates
            Peter M

            Another thing to check, if this is Windows 8 or above.

            You should disable Fast Startup for a clean reboot to occur that helps software adjust to updates and make changes that otherwise it cannot do.

            (Fast Startup only allows the machine to sleep or hibernate).

            Tutorials, for Windows 8+: Fast Startup - Turn On or Off in Windows 8

            Windows 10: Windows 10 Forums

             

            Windows 7 doesn't have the problem but one can disable Hibernation:  Hibernate - Enable or Disable - Windows 7 Help Forums

            • 3. Re: Problem With McAfee Updates
              sssmiley

              Thanks for the info, I hope that a fix will be available soon. Just to let you know, in my original post I forgot to mention that I'm running Win 7 Home Premium

              64 bit. And I'm not using the Hibernation feature.

              • 4. Re: Problem With McAfee Updates
                Peter M

                That's good.  Yes I hope the fix will be soon.

                • 5. Re: Problem With McAfee Updates
                  Peacekeeper

                  What version of Mcafee have you ie the Security center build number also

                  Check the following file and post what you see

                  Navigate to:- C:\ProgramData\McAfee\MCLOGS\VSCoreVersionInfo.txt

                  Open file ie read it and post contents

                  The  contents should be :-

                  McAfee VSCore SDK

                  Version: 15.4.0

                  Build: 583.4

                   

                  That is the version that has an update fix on I am wondering if your ISP has not updated you to that fix yet.

                   

                  Of course all this null if turning off Access Protection and trying the update as Peter suggested does not help. Remember to reenable AP.

                  • 6. Re: Problem With McAfee Updates
                    sssmiley

                    I followed your instructions, and what is displayed matches what was posted in your message.

                     

                    McAfee VSCore SDK

                    Version: 15.4.0

                    Build: 583.4

                     

                    Access Protection is currently disabled, do I need to re-enable it at this time?
                    Or should I wait until a fix is available?

                     

                    Thanks.

                    • 7. Re: Problem With McAfee Updates
                      Peacekeeper

                      Reenable it after each manual update. I do not know about a fix as those file detail imply you have the fix for the Blue screen crash which also fixed by accident 98% users with the updating issue.

                       

                      You might have some program clashing with McAfee or the program needs reinstalling. When you uninstalled did you uninstall from Programs and features and then run the MCPR removal tool as per

                      http://service.mcafee.com/FAQDocument.aspx?lc=1033&id=TS101331

                       

                      If not try that and also try running MVT from here

                      McAfee Virtual Technician

                       

                      If all this fails to help you might have a issues that 3-4 users are mentioning and the techs are gathering logs from these users. call support and ask to be escalated as the past two calls failed to help.

                      Re: Total Protection not updating

                      • 8. Re: Problem With McAfee Updates
                        sssmiley

                        Just so you know, each time that I uninstalled the software I first downloaded
                        the MCPR app. Then went into the Add/Remove Programs section of the
                        Windows Control Panel, uninstalled the software, and then I rebooted the PC.

                        Then after the reboot, I ran the MCPR app per its instructions including a
                        2nd reboot.

                         

                        Then after the 2nd reboot, I reinstalled the software.

                         

                        Also, thanks for the tip about Access Protection. I didn't know if it should be
                        disabled indefinitely or what. So I will re-enable it after the next manually run
                        update.

                         

                        I don't know if any other programs are playing havoc with McAfee or not, as the problems started the first week of August about 2 weeks after a Windows Update in mid-July, and I have not installed any new software before the
                        problems started.

                        • 9. Re: Problem With McAfee Updates
                          Peacekeeper

                          Sounds like the other issue some have not got update to work.

                           

                          I wonder there is a beta version I run that gets new updates faster when they come but in between major updates can lag a few days on engine updates. You are welcome to try that one if you so inclined

                          www.beta.mcafee.com.

                           

                          that said I would escalate the issue to a higher level tech call back.

                          1 2 Previous Next