5 Replies Latest reply on Nov 30, 2007 5:42 AM by boohbah

    EPO not updating

      Hello

      i got a hum dinger for you guys.

      My EPO server was working till 3 weeks ago.manual checkins and http pulls .
      Then all of a sudden nothing works , i mean nothing.
      the manual check in times out , the http pull fails , no packages can be viewed .any advice out there
        • 1. EPOAPPSVR log
          the EPOAPSVR log fiile is as follows
          20071113161512 I #4880 SiteMgrWrap Created instance of Site Manager
          20071113161512 I #4880 SiteMgrWrap DispEventAdvise on Site Manager succeeded
          20071113161512 I #4880 SiteMgr SetEPOMode: SiteMgr enter ePO mode, server=DPI-HOS-BCK01, port=8443, EPOUser=, Password=********
          20071113161512 I #4880 SiteMgr DALInit: Connected to DAL successful
          20071113161512 I #4880 SiteMgr SetEPOMode: Set ePO mode successful
          20071113161512 I #4880 SiteMgr DownloadSiteListThreadProc: Download sitelist thread started
          20071113161512 I #4880 SiteMgr DownloadSiteListThreadProc: Download sitelist thread ended
          20071113161512 I #4880 SiteMgr Get SiteMgr status 0
          20071113161512 I #5192 SiteMgr MirrorThreadProc: Mirror thread started
          20071113161512 I #5192 SiteMgr DownloadSiteListThreadProc: Download sitelist thread started
          20071113161512 I #5192 SiteMgr DownloadSiteListThreadProc: Download sitelist thread ended
          20071113161512 I #5192 SIM_InetMgr Starting download session for site NAIHttp
          20071113161512 I #5192 NaInet Looking for IE Proxy settings for protocol: http
          20071113161512 I #5192 NaInet Trying logged on user account privilege for impersonation
          20071113161512 I #5192 NaiInet IE Proxy settings found, Proxy Server:
          20071113161512 I #5192 NaInet Looking for IE Proxy settings for protocol: ftp
          20071113161512 I #5192 NaInet Trying logged on user account privilege for impersonation
          20071113161512 I #5192 NaiInet IE Proxy settings found, Proxy Server:
          20071113161512 I #5192 naInet HTTP Session initialized
          20071113161512 I #5192 naInet Connecting to HTTP Server using Microsoft WinInet
          20071113161512 I #5192 naInet Trying to connect to Real Server update.nai.com using INTERNET_OPEN_TYPE_PRECONFIG
          20071113161512 I #5192 naInet Connected to Server: update.nai.com on Port: 80 using WinInet
          20071113161512 I #5192 SIM_InetMgr Started download session 1 for site NAIHttp
          20071113161512 I #5192 SiteMgr MirrorThreadProc: Downloading file catalog.z from NAIHttp
          20071113161512 I #5192 SIM_InetMgr Downloading file catalog.z from session 1, LocalDir=C:\WINDOWS\TEMP\nai8E.tmp\00000000, RemoteDir=
          20071113161512 I #5192 naInet Open URL: http://update.nai.com:80/Products/CommonUpdater/catalog.z
          20071113161512 I #5192 naInet Trying to download using Microsoft WinInet library
          20071113161512 I #5192 naInet Connecting to Server update.nai.com using INTERNET_OPEN_TYPE_PRECONFIG
          20071113161512 I #5192 naInet No resume download needed, calling InternetOpenUrl
          20071113161513 I #5192 naInet Downloading a file of total size: 2852, content-length: 2852
          20071113161517 I #5192 naInet Downloaded 2852 bytes this time
          20071113161517 I #5192 naInet Downloaded 0 bytes this time
          20071113161517 I #5192 SIM_InetMgr Downloaded file catalog.z successfully in session 1
          20071113161517 e #5192 SiteMgr MirrorThreadProc: Failed to decrypt and extract C:\Program Files\Network Associates\ePO\3.6.0\Db\software\catalog.z, hr=-106
          20071113161517 I #5192 McUpload Start http session login...
          20071113161517 I #5192 McUpload End http session login, status=0
          20071113161517 I #5192 McUpload Http response status code = 200
          20071113161517 I #5192 naInet HTTP Session closed
          20071113161517 I #5192 naInet ------------------------------------------------------------
          20071113161517 I #5192 SIM_InetMgr Session 1 ended, result=1
          20071113161517 I #5192 SiteMgr MirrorThreadProc: Mirror thread ended
          20071113161517 x #4880 SiteMgr SiteMgr main control final release...
          • 2. RE: EPOAPPSVR log
            Do you use a proxy in your environment?
            • 3. RE: EPOAPPSVR log
              ok, so the fatal error is here :

              20071113161517 e #5192 SiteMgr MirrorThreadProc: Failed to decrypt and extract C:\Program Files\Network Associates\ePO\3.6.0\Db\software\catalog.z, hr=-106


              its possible this file is corrupt, but because it needs to be written to, etc when dats are checked in, this would explain the symptoms you are seeing.

              how big is this file - it should be at least 3 kb or more.

              if you have a backup from a time when it worked ok, it may be worth restoring the whole of the \software\ folder - this would rectify a corrupted catalog.

              if you have any distributed repos, find the catalog from the root of the repo - is it the same exact size ? - it may well not be ( which is a good thing) try backing up the corrupted one, and replacing it with the one from a distributed repo ?

              HTH
              • 4. RE: EPOAPPSVR log
                BOOBAH HOOTS AND HE SCORES ::)

                once again thtnks for that , it worked like a charm. Loaded the backup of the software directory and it worked.

                Thanks for that
                • 5. RE: EPOAPPSVR log
                  it worked ? excellent !

                  it is worth mentioning for others reading the thread to always treat the repository contents as one unit,

                  ie move files inside the \software\ folder all in one, , restore as one, copy as one, etc.