7 Replies Latest reply on Nov 11, 2009 2:09 PM by acidfire52

    Deleting Superagent repository

      About 9 months ago, when testing ePO, we created a superagent repository. This is now defunct and we want to delete it.

      When repository replication is run, the replication ignores it on the scheduled configuration, but tries to replicate on its own default replication schedule.

      I cannot seem to find a way to delete this repository. When highlighted, it only gives the 'Edit' option. Is there any way that it can be deleted?

        • 1. RE: Deleting Superagent repository
          SA Repositories are configured via the epo agent policy. So just edit the agent policy for the machine holding the SA rep and uncheck the SA function. Then send a wakeup call to the client to let it enforce the new policy. The SA repository should then automatically disappear in the repository list.

          Cheers Tom
          • 2. RE: Deleting Superagent repository

            I have already done that by removing the 'enable SA functionality' tick mark.

            On the normal replication that is set for every 4 hours (replicate repository), it is ok and ePO does not show the superagent repository, but on the default replication (replicate now) it tries to do so. I want to remove the defunct repository from the list completely so it does not show at all.
            • 3. RE: Deleting Superagent repository

              Did you ever determine how to completely remove a repository?

              I accedentily assigned a policy configured to make Agents in to Super Agents to a location in ePO. So, now I have a LOT of Super Agents in that location (on that subnet).
              • 4. Re: Deleting Superagent repository

                I also have this issue.  Have a lot of SuperAgent repositories, some for machines that no longer exist.  Have removed functionality for all machines, but they still exist.  Have tried cleaning out the xml files, but it keeps recreating them.

                Any ideas?

                • 5. Re: Deleting Superagent repository
                  Sailendra Pamidi

                  If the machine(s) which are configured by Agent Policy are no longer reporting back to ePO, then changing the policy will have no affect (the SA repository entry would remain). Refer to KB60470 for removing the defunct Super Agent repositories.


                  From KB60470:

                  The computer hosting the SuperAgent repository was removed from the network without first uninstalling the agent. Because the agent was never successfully removed first from the computer, the SiteList.xml file still lists this non-active SuperAgent repository entry.

                  The computer was deleted from the ePO system tree, with the option to Uninstall the agent selected. This marks the computer as Type 24 in the ePO database, forcing the agent has to call back to the ePO server for the entry to be removed from the database. This will not happen since the computer is no longer available in the network

                  • 6. Re: Deleting Superagent repository

                    the SA repo will automatically delete when the machine checks back in to ePO with the property of bEnableSuprtAgentRepository returns 0. If the machine never reports back in, then this property won't be set. You can try deleting the machine from the system tree (dont' check remove agent) and then cycle the ePO services. If that still doesn't work, You will have to manually edit the SiteMgr.xml to remove the element for that repo.


                    I would be EXTREMELY careful in editing the SiteMgr.xml. You can cause serious issues if you don't do it properly. Make sure you stop the ePO services while editing it and backup a copy of the file before editing it.

                    • 7. Re: Deleting Superagent repository

                      This works for me, thanks.  I looked at that before, but it didn't click that I needed to remove the clients with the uninstall option checked.  Removed the 5 I tested it with.


                      Thanks again.