6 Replies Latest reply on Jul 17, 2009 10:21 AM by XADMIN

    Cannot send agent install!

      Hi Guys...
      I have a problem when im trying to install the agent from the EPO console ... And in true sytle there is almost No help...and No error messages that have helped ...

      I updated the Epo agent to version 3.5 thinking it would be better than the previous version only to find i couldnt install it on any of the machines... although all of the old machine still seem to working fine ... everything is still updating and working correctly, as far as i can tell but i cannot install on any new machines... and when i try to make a Framework Package for installing the agent it completes successfully but when i attempt to run it i get an error (which BTW doesnt get logged in the event viewer!)

      it refers to this

       

      FrmInst_<COMPUTERNAME>.log



      this is the error im getting

        • 1. RE: Cannot send agent install!
          Does the user account you specify during the Framework Package creation have local administrative rights on the computers you are trying to setup?
          • 2. RE: Cannot send agent install!
            metalhead
            As you installed the package on Windows 2000 SP4 (its the same for Windows XP) you will also need to pay attention to this (excerpt from ePO-README.TXT):

             


            20. ISSUE:
            Custom agent installation packages
            (FRAMEPKG.EXE) with embedded user
            credentials might not install successfully
            on computers using these operating systems:

            - Windows 2000 Advanced Server with Service
            Pack 4 or later.
            - Windows 2000 Server with Service Pack 4
            or later.
            - Windows Server 2003 Enterprise.
            - Windows Server 2003 Standard.

            RESOLUTION:
            Make the following changes to the security
            settings on computers using the operating
            systems listed above before installing
            custom agent installation packages on them:

            a. Log on to the desired computer using a
            user account with local administrator
            permissions.

            b. Run SECPOL.MSC to open the "Local
            Security Settings" dialog box.

            c. In the console tree under "Security
            Settings" | "Local Policies," select
            "User Rights Assignment."

            d. In the details pane, double-click
            "Impersonate a client after
            authentication" in the "Policy" column to
            open the "Local Security Policy Setting"
            dialog box.

            e. Click "Add" to open the "Select Users or
            Groups" dialog box.

            f. Select the user or group that the
            end-user is likely to run as; for
            example, "Everyone" or "Users," then
            click "Add."

            g. Click "OK" twice to save the current
            entries.

            h. On Windows 2000 computers, you need to
            restart the computer before the changes
            become effective.

            At press time, information about this issue
            (impersonate a client after authentication)
            and instructions for troubleshooting it were
            available on the Microsoft web site:

            http://support.microsoft.com/default.aspx?scid=kb;en-us;821546


            You can also set this via Windows Grouppolicies ...

            Cheers Tom
            • 3. RE: Cannot send agent install!
              I'm having these issues as well.

              I'm installing the framepkg locally on Vista. I have administrative control, I've checked file sharing...I've even tried creating with no credentials.

              20090716163026 I #548 Stub Pkg
              20090716163026 I #548 Stub Pkg START ["C:\Users\xAdministrator\Desktop\offline_FramePkg.exe" ]
              20090716163026 I #548 Common Pkg CreateDirectory (C:\Users\XADMIN~1\AppData\Local\Temp\unz5274.tmp)
              20090716163027 I #548 Stub Pkg System=0
              20090716163027 I #548 Common Pkg CreateProcess (C:\Users\XADMIN~1\AppData\Local\Temp\unz5274.tmp\FrmInst.exe, /CreateService="C:\Users\xAdministrator\Desktop\offline_FramePkg.exe" /LOGDIR="C:\Users\XADMIN~1\AppData\Local\Temp\NAILogs" /Cleanup2="C:\Users\XADMIN~1\AppData\Local\Temp\unz5274.tmp" /EmbeddedUsername="xadministrator" /EmbeddedDomain="." /EmbeddedPassword="************************************************************ ****" /Install=Agent)
              20090716163027 I #548 Common Pkg WaitForSingleObject (C:\Users\XADMIN~1\AppData\Local\Temp\unz5274.tmp\FrmInst.exe, -1)
              20090716163027 I #2668 naCmnLib Ins Random seed = 0x2676****
              20090716163027 I #2668 Setup Ins START [/CreateService="C:\Users\xAdministrator\Desktop\offline_FramePkg.exe" /LOGDIR="C:\Users\XADMIN~1\AppData\Local\Temp\NAILogs" /Cleanup2="C:\Users\XADMIN~1\AppData\Local\Temp\unz5274.tmp" /EmbeddedUsername="xadministrator" /EmbeddedDomain="." /EmbeddedPassword="************************************************************ ****" /Install=Agent]
              20090716163027 I #2668 Setup Ins Windows 6.0.6001 Service Pack 1
              20090716163027 I #2668 Setup Ins Restarting as a service to get System rights
              20090716163027 I #2668 Setup Ins This package seems to be created by ePO 3.5 or higher
              20090716163027 E #2668 LgOnUsr Ins Error trace:
              20090716163027 E #2668 Thread Ins [Main thread]->
              20090716163027 E #2668 Setup Ins [Restarting as a service to get System rights]->
              20090716163027 E #2668 Setup Ins [Possibly impersonate]->
              20090716163027 E #2668 LgOnUsr Ins [OpenThreadToken]->
              20090716163027 E #2668 LgOnUsr Ins error 5: Access is denied.
              20090716163027 E #2668 UI Ins Error trace:
              20090716163027 E #2668 Thread Ins [Main thread]->
              20090716163027 E #2668 UI Ins There was an unexpected error during setup execution. See this log file for details: C:\Users\XADMIN~1\AppData\Local\Temp\NAILogs\FrmInst_MININT-0EFK5S4.log
              20090716163032 I #2668 Thread Ins Exit program
              20090716163032 I #2668 Setup Ins END 1603
              20090716163037 I #548 Stub Pkg END 1603
              • 4. RE: Cannot send agent install!
                Sk1dMARK
                Wow, this was an old thread you resurrected. You should probably start your own thread as the OP was having issues using ePO to push and you are attempting a manual install locally with a different OS. It may help get you the answer and will definitely help people searching later on.

                I digress and now on to the problem.

                Is User Access Control enabled? If enabled, you really don't have admin rights. You will need to perform the install one of a couple different ways.

                Take your agent without embedded credentials and place it on the desktop.

                1.) Right click on it and select "Run as administrator" and then it should work.

                Or

                2.) Open up a command prompt that has administrative rights (using the runas command) and perform a command line install. Personally, I prefer this method, "framepkg.exe /install=agent"


                Hopefully this will work for you.


                Regards,

                Mark
                • 5. RE: Cannot send agent install!
                  I tried both of those ways and got the same result as before.

                  Are there some secpol settings that I might need to check. This is not an "out of the box" distribution of Vista Enterprise.
                  • 6. RE: Cannot send agent install!
                    I've tried both of those things with the same result.

                    Are there specific secpol settings I may need to check/change? This is not a standard "out of the box" version of Vista Enterprise.