1 Reply Latest reply on Jul 20, 2015 4:54 PM by Jon Scholten

    McAfee Documentation Download asking for Kerberos Authentication

    clath13

      Good morning,

      Not quite sure how to explain this.  I log into the support.mcafee.com site, I enter my grant number to download patches, etc., I click on a documentation link and I get an HTTP 404 not found.  I do the exact same steps on a different Internet access point - behind our partners Web Gateways, not ours - and I can download the doc.  I fired up rule tracing on my web gateway and see this:

       

       

      Where do I have something misconfigured that makes the Gateway think I need to perform internal Kerberos authentication to get access to a document hosted by McAfee?

       

      Thanks,

      Claire

        • 1. Re: McAfee Documentation Download asking for Kerberos Authentication
          Jon Scholten

          Hi Claire,

           

          Thats a red herring. When authentication is enabled, you will see the "dark figure" whenever authentication occurs. You likely need to wait a minute for the rest of the traces to appear (as they are probably sitting in the buffer).

           

          It's important to understand that authentication occurs over multiple steps.

          ---- Rule trace #1 -----

          1) You make a request (no credentials included)

          2) MWG responds asking for credentials (Basic, NTLM, Kerberos)

           

          ---- Rule trace #2 -----

          3) You make a new request (same TCP connection) including credentials... lets say Kerberos

          4) MWG authorizes the request, but web server returns a 404

           

          As far as why you get a 404, if you have an SR open, we can take a look at that.

           

          Best Regards,

          Jon