7 Replies Latest reply on Jul 16, 2015 3:19 PM by aguzman

    ePO 5.1.1 cannot deploy RSD 4.7.2 or 5.0.1

    aguzman

      Hello All,

       

      I am unable to install the RSD sensor using ePO 5.1.1. When deploying RSD I get the following error:

      RSD Failed.jpg

      I have tried removing all of the RSD software from Software Manager as well as the Master Repository, (we only have the 1 repo), and reinstall it. I have even tried downloading the software and manually checking it into our Repo, but we are still unable to deploy using ePO.

      One thing I noticed when trying to install RSD 5.0.1, after the software is checked into the repository, it does not show up under the software manager list as checked in. It does however show up under Master Repository as installed.

       

      I've read a previous post about this suggesting to manually delete the software from the C: drive location. I have done this and it didn't help. Also, in that post it was mentioned change the software location the "Install RSD" job points to. However, this is NOT a configurable task. Is there any way to verify where the job task is pointing to in order to make sure it is trying to install from the correct location?

       

      Does anyone know what causes this issue or how to resolve it?

        • 2. Re: ePO 5.1.1 cannot deploy RSD 4.7.2 or 5.0.1
          aguzman

          Thank you for that KB article.

          Workaround #2 seemed to work for one of my test machines, so I will continue testing using that workaround.

          Workaround #1 seemed to fail.

           

          Here is an output of the agent log when I attempted to install RSD using the workaround #1 method.

           

          7/15/2015, 12:24:27 PM Info Updater Checking update packages from repository <EPO SERVER>.

          7/15/2015, 12:24:27 PM Info Scheduler Scheduler: Invoking task [Install RSD]...

          7/15/2015, 12:24:27 PM Info Updater Downloading catalog.z.

          7/15/2015, 12:24:27 PM Info Updater Extracting catalog.z.

          7/15/2015, 12:24:28 PM Info Updater Loading update configuration from: catalog.xml

          7/15/2015, 12:24:29 PM Info Updater Extracting PkgCatalog.z.

          7/15/2015, 12:24:29 PM Info Updater Verifying PkgCatalog.z.

          7/15/2015, 12:24:29 PM Info Updater Downloading PkgCatalog.z.

          7/15/2015, 12:24:29 PM Info Updater Verifying MampDet.McS.

          7/15/2015, 12:24:29 PM Info Updater Verifying MampDet.McS.

          7/15/2015, 12:24:29 PM Info Updater Downloading MampDet.McS.

          7/15/2015, 12:24:29 PM Info Updater Verifying MampDet.McS.

          7/15/2015, 12:24:29 PM Info Updater Loading update configuration from: PkgCatalog.xml

          7/15/2015, 12:24:30 PM Info Updater Downloading setup.exe.

          7/15/2015, 12:24:30 PM Info Updater Downloading MampDet.McS.

          7/15/2015, 12:24:30 PM Info Updater Installing RSD_____4700.

          7/15/2015, 12:24:30 PM Info Updater Verifying MampDet.McS.

          7/15/2015, 12:24:31 PM Info Updater Verifying setup.exe.

          7/15/2015, 12:24:35 PM Info Agent Agent communication session closed

          7/15/2015, 12:24:35 PM Info Agent No package received from ePO Server

          7/15/2015, 12:24:35 PM Info Agent Agent communication session started

          7/15/2015, 12:24:35 PM Info Agent Sending the next batch of 1 data channel items

          7/15/2015, 12:24:35 PM Info Agent Agent is connecting to ePO server

          7/15/2015, 12:24:37 PM Info Agent No package received from ePO Server

          7/15/2015, 12:24:37 PM Info Agent Agent is connecting to ePO server

          7/15/2015, 12:24:37 PM Info Agent Agent communication session closed

          7/15/2015, 12:24:37 PM Info Agent Agent communication session closed

          7/15/2015, 12:24:37 PM Info Agent Package uploaded to ePO Server successfully

          7/15/2015, 12:24:37 PM Info Agent Agent is connecting to ePO server

          7/15/2015, 12:24:37 PM Info Agent Agent communication session started

          7/15/2015, 12:24:37 PM Info Agent Agent communication session started

          7/15/2015, 12:25:06 PM Info Updater Update Finished

          7/15/2015, 12:25:06 PM Info Updater Error occurred while installing RSD_____4700.

           

          Also, since this task failed, I attempted to deploy the RSD sensor using workaround #2 on this same machine. However, I got an error...

           

          Is there any way to cancel\Kill this task? I do not see it listed under the Server Tasks Log like how I normally see a wakeup call task.

           

          Any idea when the tentative date is for the Q3 2015 release of ePO 5.1.3 or ePO 5.3.1?

          • 3. Re: ePO 5.1.1 cannot deploy RSD 4.7.2 or 5.0.1
            mmcgary


            -Your Agent output seems to confirm the issue so I believe either solution 1 or 2 will apply depending on which errors you are seeing from the top of the article.

             

            -You may need to restart the services for EPO to clear out those Run Now tasks.

             

            -Nope no more information has been released to us other than Q3 for both.

            • 4. Re: ePO 5.1.1 cannot deploy RSD 4.7.2 or 5.0.1
              aguzman

              Thank you for the great feedback and information. I was trying to avoid restarting the EPO services on the server but I guess I have no other choice.

               

              Thanks for all the help and advise.

              • 5. Re: ePO 5.1.1 cannot deploy RSD 4.7.2 or 5.0.1
                aguzman

                ***UPDATE***


                The restart of the McAfee services did not clear the second error of a "already contains a Rogue Sensor deployment task". I even restarted the server to make sure everything was restarted and I still cannot deploy to the computer I tried to install RSD on using Workaround #1.

                 

                Any other way to cancel the Rogue Sensor deployment task?

                • 6. Re: ePO 5.1.1 cannot deploy RSD 4.7.2 or 5.0.1
                  mmcgary

                  Select the system and Actions/Agent/Modify tasks on a single system and you should see an RSD deployment in there. Delete the task and attempt the deployment again.

                  • 7. Re: ePO 5.1.1 cannot deploy RSD 4.7.2 or 5.0.1
                    aguzman

                    I just found this as you posted that note. Did exactly that and it cleared the error.

                     

                    Thank You.