2 Replies Latest reply on Jul 8, 2015 1:51 PM by mrjones1914

    EMM Hub and ePO Server Unable to Communicate

    mrjones1914

      Up until today, communication between my EMM 12.0.5 Internal Hub (running on Server 2012 R2) and the ePO server has worked just fine. Suddenly, every time I navigate to Server Settings > Enterprise Mobility Management in ePO, I immediately get "Unknown error has occurred". It is apparently unable to retrieve the settings from the Hub.

       

      Looking at the Event Viewer on the Hub, I am now seeing this:

       

      WebHost failed to process a request.

      Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/5593166

      Exception: System.ServiceModel.ServiceActivationException: The service '/EMMHub/PushNotifierGateway.svc' cannot be activated due to an exception during compilation.  The exception message is: Could not load file or assembly 'App_Web_bai-fzzs, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.. ---> System.IO.FileNotFoundException: Could not load file or assembly 'App_Web_bai-fzzs, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

      File name: 'App_Web_bai-fzzs, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null'

         at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)

         at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

         at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

         at System.Reflection.Assembly.Load(String assemblyString)

         at System.ServiceModel.Activation.ServiceHostFactory.CreateServiceHost(String constructorString, Uri[] baseAddresses)

         at System.ServiceModel.ServiceHostingEnvironment.HostingManager.CreateService(Stri ng normalizedVirtualPath)

         at System.ServiceModel.ServiceHostingEnvironment.HostingManager.ActivateService(St ring normalizedVirtualPath)

         at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvail able(String normalizedVirtualPath)

       

      WRN: Assembly binding logging is turned OFF.

      To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

      Note: There is some performance penalty associated with assembly bind failure logging.

      To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

       

         --- End of inner exception stack trace ---

         at System.ServiceModel.ServiceHostingEnvironment.HostingManager.EnsureServiceAvail able(String normalizedVirtualPath)

         at System.ServiceModel.ServiceHostingEnvironment.EnsureServiceAvailableFast(String relativeVirtualPath)

      Process Name: w3wp

      Process ID: 4252

       

      I cannot figure out what has changed in the last couple of days. I was wondering if anyone else has seen this message, or have any idea where it originates and how you resolved it?

       

      Any guidance you can provide would be greatly appreciated!