5 Replies Latest reply on Jun 14, 2015 10:32 PM by markbkk88

    Mcafee EPO version 5.3.0 Evaluation

    markbkk88

      Dear Community

       

      I am a newbie to Mcafee Epo but have 12 years experience in System admin. I have been asked by my company to evaluate this product so have set up a hyper-v test lab with a fully functional domain, 2 servers and 2 workstations.I have downloaded 5.3 evaluation copy of epo and installed onto a windows 2008 r2 server.

      I have deployed the agent to my devices and the product improvement program 1.5.0 and everything appears to be running smoothly.

       

      My problem is I cannot get any other software to deploy.

       

      I have downloaded and ckeckin the products below and it appears under My products:

       

      mcaf1.png

       

      The software also appears in package if I create a new product deployment project:

      mcaf2.png

       

      However on creation of the deployment project – the installation never gets past pending:

       

      mcaf3.png

       

       

      I also noticed if I try to create a deployment through Customize Installation on the dashboard, the checkin software is not there.

       

      mcaf4.png

       

       

      If anyone has any ideas I would love to hear from you…..could it be licencing as I’m using Evaluation software?

       

      Also as I am a newbie…any tips on troubleshooting the issue would be more than helpful!

       

      All the best!

       

      Kind Regards Mark

        • 1. Re: Mcafee EPO version 5.3.0 Evaluation
          norbertg

          I've noticed with Agent 5 that I have checked in it doesn't appear under master repository since it's in Eval whereas 4.8 does cos it's in current branch.

           

          You also need to check in the Extensions under Menu - Extensions. This might be the reason why you can't see anything under checking software..

           

          As for deployment, somethings are product deployments somethings are product updates (e.g vse 8.8 to 8.8 patch 5). I had to create a client task and use the agent product update feature to update our VSE 8.8 to 8.8p5. A new install might be different and a product deployment.

          • 2. Re: Mcafee EPO version 5.3.0 Evaluation
            markbkk88

            Thanks for the pointer regarding the extensions........I checkin the extensions  for the products and they were then available for deployment.

             

            However on creating a new product deployment and applying to my systems they are again all stuck on pending.

            Is there a log to check why this "pending" status?

             

            Will take a closer look at the install guide for each product to see if there is a method for deployment as suggested in your second comment....Thanks for your help

            • 3. Re: Mcafee EPO version 5.3.0 Evaluation
              Daniel_S

              What do you see when you open the agent-monitor on the clients after sending the tasks? are they reacting in anyway?

              I think it´s a problem in the deployment task.

              What happens when you trigger it manually from within the systemtree to a single system?

              • 4. Re: Mcafee EPO version 5.3.0 Evaluation
                norbertg

                I find McAfee has a lot of log files depending on the product.

                 

                In ePO you can click on Menu, Server Task Log you might find some info about your current deployment.

                 

                You will probably need to goto the client and see why it's getting stuck. Google your product e.g VirusScan Enterprise log location.

                 

                You might need to open some ports on the client firewall.

                 

                The Agent by default is set to pull changes down every hour.

                 

                Sorry I don't have any doc's on me at the moment. These are where I would start.

                 

                I'm sure a McAfee expert will comment soon enough.

                 

                Edit: Agent 5 is very buggy, I found 4.8 stable. Might be worth testing that if you don't get much success.

                • 5. Re: Mcafee EPO version 5.3.0 Evaluation
                  markbkk88

                  Thanks Norbet and Daniel for the troubleshooting tips....

                  For testing I chose  Endpoint security 10 ...after reading the install guide for this I found it has a pre-req of Agent 5.0 ..... The Epo evaluation agent I downloaded is 4.8.

                  When I checked the client agent logs I can see an updater status of "Error installing product. The minimum version of agent required is not installed."

                   

                  I downloaded and checked in VIRUSSCAN 8, created a product deployment and the installs ran smoothly..

                   

                  Unlucky to choose Endpoint 10 to start.........but have learnt a lot more about Epo because of this!

                   

                  Thanks again!