1 Reply Latest reply on Jun 3, 2015 7:09 PM by norbertg

    Agent 5.0 duplicate GUID

    norbertg

      Looks like my batch script to clean up duplicate GUID when using images no longer work as it won't allow me to remove the guid values. This is with admin rights. Error below:

       

      G:\IT\Software - Head Office\McAfee VSE>REG delete "HKLM\SOFTWARE\Network Associ
      ates\ePolicy Orchestrator\Agent" /v AgentGUID /F
      ERROR: The system was unable to find the specified registry key or value.
      G:\IT\Software - Head Office\McAfee VSE>REG delete "HKLM\SOFTWARE\Network Associ
      ates\ePolicy Orchestrator\Agent" /v MacAddress /F
      ERROR: The system was unable to find the specified registry key or value.
      G:\IT\Software - Head Office\McAfee VSE>REG delete "HKEY_LOCAL_MACHINE\SOFTWARE\
      Network Associates\ePolicy Orchestrator\Agent" /v AgentGUID /F
      ERROR: The system was unable to find the specified registry key or value.
      G:\IT\Software - Head Office\McAfee VSE>REG delete "HKEY_LOCAL_MACHINE\SOFTWARE\
      Network Associates\ePolicy Orchestrator\Agent" /v MacAddress /F
      ERROR: The system was unable to find the specified registry key or value.
      G:\IT\Software - Head Office\McAfee VSE>REG delete "HKEY_LOCAL_MACHINE\SOFTWARE\
      Wow6432Node\Network Associates\ePolicy Orchestrator\Agent" /v AgentGUID /F
      ERROR: Access is denied.
      G:\IT\Software - Head Office\McAfee VSE>REG delete "HKEY_LOCAL_MACHINE\SOFTWARE\
      Wow6432Node\Network Associates\ePolicy Orchestrator\Agent" /v MacAddress /F
      ERROR: Access is denied.
      **** Silently installing FramePackage ****
      ****           Please Wait            ****
      G:\IT\Software - Head Office\McAfee VSE>FramePkg.exe /forceinstall /install=agen
      t /silent

       

       

      And this is what the script looks like:

       

      cd %~dp0
      @echo ******************************
      @echo You only need to run this if you have imaged the PC.
      @echo Terminate the job now if it is not a imaged PC.
      @echo ******************************
      pause
      cls
      @echo ******************************
      @echo Make sure FramePkg.exe is in the same location as the restguid.cmd file.
      @echo If it is not terminate the job now.
      @echo ******************************

      pause
      cls
      :: Delete AgentGUID and MacAddress
      @echo **** Deleting AgentGUID and MacAddress ****
      :: XP
      REG delete "HKLM\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent" /v AgentGUID /F
      REG delete "HKLM\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent" /v MacAddress /F
      :: Win 7 x86
      REG delete "HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent" /v AgentGUID /F
      REG delete "HKEY_LOCAL_MACHINE\SOFTWARE\Network Associates\ePolicy Orchestrator\Agent" /v MacAddress /F
      :: Win 7 x64
      REG delete "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Network Associates\ePolicy Orchestrator\Agent" /v AgentGUID /F
      REG delete "HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Network Associates\ePolicy Orchestrator\Agent" /v MacAddress /F
      :: Silently installing FramePackage
      @echo **** Silently installing FramePackage ****
      @echo ****           Please Wait            ****
      FramePkg.exe /forceinstall /install=agent /silent

      cls

      :: Completed
      @echo Done
      pause


      How can I fix this?