4 Replies Latest reply on Apr 15, 2015 1:22 PM by davidb

    Auto Update not working on McA Enterprise v8.8

    davidb

      Scan Engine 5700.7163, DAT version 7771.0000

       

      Problem: My Auto-Update will not auto-update on schedule.

       

      1) Manual updates work fine, no errors in error log.

      2) I manually reschedule the auto update to commence as I'm watching it, and nothing happens.

      3) I checked the accessibility of the destination site (which came up fine, so no firewalls....).

      4) I re-ran the MAT.reg installer to insure the registry had the automatic setting installed to run (in my case) at 0100hrs..

      5) I checked the properties to insure the destination site was typed in correctly, correct port, etc..

       

      It's clearly a server issue since for the 8 enterprise servers in that particular VLAN, 3 servers work fine, the other 5 servers don't.

       

      Should I simply try reinstalling Auto-Update...?

        • 1. Re: Auto Update not working on McA Enterprise v8.8
          Peter M

          Moved to VSE for a faster response.

          ---

          Peter

          Moderator

          • 2. Re: Auto Update not working on McA Enterprise v8.8
            wwarren

            You can't reinstall Autoupdate; maybe you meant to reinstall the McAfee Agent?

            If you want to take the approach of making changes without knowing why it's failing, sure, that's something you can try.

             

            What I would do is have you find out why it's failing though:

            KB82170, How to enable debug logging for McAfee Agent 5.x for Windows (complete Solution 1 & 2)

            KB58966, How to enable debug logging for McAfee Agent 4.x for Windows (complete Solution 1 & 2)

             

            1. Whichever version of MA you're using, enable debug logging for it. That includes setting a larger log file size.
            2. Reboot. The reboot acts as a nice marker and reference point.
            3. Run Process Monitor, no filters (this records changes to the registry and file system, providing a forensic trail if needed)
            4. Reschedule the Task to run _soon_ (like 2 mins in the future). Save the change.
            5. Wait for the Task time to run...
            6. If the task did not run, save the Procmon capture - all events, in native PML format.  If the task did run, well, then there's no issue.

             

            Review the Agent_<computername> log and McScript log for what actions occurred when the task was meant to kick off.

            Review the Procmon log for confirmation the task was actually scheduled. (You probably will need Support assistance for that).

            • 3. Re: Auto Update not working on McA Enterprise v8.8
              davidb

              Obviously I'd like the right solution. So tell me where to find the issue...?  If I cannot reinstall AU, then yes, McAfee Agent.

               

              I'll try the debug logging and verify that way.

              • 4. Re: Auto Update not working on McA Enterprise v8.8
                davidb

                I can't find the ePO console on the server.., what's the executable name...?

                 

                I'm running Agent v4.0