5 Replies Latest reply on Feb 11, 2015 3:40 PM by Karel

    SAE+ 3.5 Update Extension 3.5.0.328

    Karel

      Hi,

       

      Anyone else having issues with the update of the SAE+ 3.5 to version 3.5.0.328 for the extension?

      Everything updated except the extension causing my dashboards and queries to fail ofcourse.

      And i can't uninstall anything cause the extension is missing.

       

      When updating from version 3.5.0.311 to 3.5.0.328 i get following error.

       

       

      Log Messages

       

       

      2/2/15 1:04:16 PMStarted: Check In Components
      2/2/15 1:04:17 PMDownloading the following component:
      2/2/15 1:04:17 PMSAE 3.5 Patch 3 Extension (type EXTENSION) - filename=SITEADVMETA_3321.zip
      2/2/15 1:04:18 PMDownloading file C:\PROGRA~2\McAfee\EPOLIC~1\DB\SoftwareManager\1173\3.5\SITEADVMETA_3321.zip.
      2/2/15 1:04:20 PMSuccessfully downloaded file C:\PROGRA~2\McAfee\EPOLIC~1\DB\SoftwareManager\1173\3.5\SITEADVMETA_3321.zip.
      2/2/15 1:04:20 PMChecking in extension 'SAE 3.5 Patch 3 Extension'.
      2/2/15 1:04:26 PMCommand Failed: Installation error: determine-epo-env: [echo] using.epo45 is true set-props: [echo] set-props: previous.version.nobuildnum is 3.5.0 [echo] from-2.0.0 is ${from-2.0.0} [echo] from-2.0.1 is ${from-2.0.1} [echo] from-3.0.0 is ${from-3.0.0} [echo] from-3.0.2 is ${from-3.0.2} [echo] from-3.0.0 is ${from-3.0.3} [echo] from-3.5.0 is true [echo] from-3.5.1 is ${from-3.5.1} init-common: init-upgrade: [echo] init-upgrade called for SITEADVMETA from 3.5.0.311 to 3.5.0.328 upgrade-context: upgrade-policy: uninstall-event-parser: upgrade-from-2.0.0: upgrade-from-2.0.1: upgrade-from-3.0.0: upgrade-from-3.0.2: upgrade-from-3.0.3: upgrade-from-3.5.0: [echo] Upgrading from 3.5.0 ... upgrade-db-3.0.3-to-3.5.1: [echo] calling sql/SAE35Patch1UpgradeScript.sql [execute-sql] upgrade-db-3.5.1-to-3.5.2: [echo] calling sql/SAE35Patch2Upgrade.sql BUILD FAILED C:\PROGRA~2\McAfee\EPOLIC~1\server\extensions\installed\SITEADVMETA\3.5.0.328\i nstall.xml:331: The following error occurred while executing this line: C:\PROGRA~2\McAfee\EPOLIC~1\server\extensions\installed\SITEADVMETA\3.5.0.328\i nstall.xml:420: java.sql.SQLException: Violation of UNIQUE KEY constraint 'IX_EPOPolicySettingValues_SettingSectionSetting'. Cannot insert duplicate key in object 'dbo.EPOPolicySettingValues'. The duplicate key value is (1074, Eventing, bDisableEventing). at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:372) at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2985) at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2418) at net.sourceforge.jtds.jdbc.TdsCore.getMoreResults(TdsCore.java:674) at net.sourceforge.jtds.jdbc.JtdsStatement.processResults(JtdsStatement.java:614) at net.sourceforge.jtds.jdbc.JtdsStatement.executeSQL(JtdsStatement.java:573) at net.sourceforge.jtds.jdbc.JtdsStatement.executeImpl(JtdsStatement.java:810) at net.sourceforge.jtds.jdbc.JtdsStatement.executeUpdate(JtdsStatement.java:1289) at net.sourceforge.jtds.jdbc.JtdsStatement.executeUpdate(JtdsStatement.java:1242) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.ja va:43) at java.lang.reflect.Method.invoke(Method.java:606) at com.mcafee.orion.core.db.sqlserver.JtdsStatementRetryInvocationHandler.invoke(J tdsStatementRetryInvocationHandler.java:53) at com.sun.proxy.$Proxy5.executeUpdate(Unknown Source) at com.mcafee.orion.core.db.base.SqlUtil.executeSql(SqlUtil.java:100) at com.mcafee.orion.core.ext.tasks.SqlTask.execute(SqlTask.java:58) at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291) at sun.reflect.GeneratedMethodAccessor768.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
      2/2/15 1:04:26 PMFailed to check in extension 'SAE 3.5 Patch 3 Extension'.
      2/2/15 1:04:26 PMCompleted: Check In Components (The component(s) failed to check in.)

       

       

      If i read the logs correctly it's conflicting with SQL unique values but can't seem to solve it.

      Anyone have any issues or idea's?

        • 1. Re: SAE+ 3.5 Update Extension 3.5.0.328
          jjandebeur

          I am having the same exact issue.  Also unable to remove the patch 3 extension.

           

          2/3/15 4:15:35 PMStarted: Remove Components
          2/3/15 4:15:35 PMRemoving extension 'SAE 3.5 Patch 3 Extension'.
          2/3/15 4:15:36 PMCommand Failed: an error occurred while trying to uninstall the extension SITEADVMETA.
          2/3/15 4:15:36 PMFailed to remove extension 'SAE 3.5 Patch 3 Extension'.
          2/3/15 4:15:36 PMCompleted: Remove Components (The component(s) failed to be removed.)

           

           

          2/3/15 3:18:27 PMStarted: Check In Components
          2/3/15 3:18:28 PMDownloading the following component:
          2/3/15 3:18:28 PMSAE 3.5 Patch 3 Extension (type EXTENSION) - filename=SITEADVMETA_3321.zip
          2/3/15 3:18:29 PMDownloading file C:\PROGRA~2\McAfee\EPOLIC~1\DB\SoftwareManager\1173\3.5\SITEADVMETA_3321.zip.
          2/3/15 3:18:30 PMSuccessfully downloaded file C:\PROGRA~2\McAfee\EPOLIC~1\DB\SoftwareManager\1173\3.5\SITEADVMETA_3321.zip.
          2/3/15 3:18:30 PMChecking in extension 'SAE 3.5 Patch 3 Extension'.
          2/3/15 3:18:35 PMCommand Failed: Installation error: determine-epo-env: [echo] using.epo45 is true set-props: [echo] set-props: previous.version.nobuildnum is 3.5.0 [echo] from-2.0.0 is ${from-2.0.0} [echo] from-2.0.1 is ${from-2.0.1} [echo] from-3.0.0 is ${from-3.0.0} [echo] from-3.0.2 is ${from-3.0.2} [echo] from-3.0.0 is ${from-3.0.3} [echo] from-3.5.0 is true [echo] from-3.5.1 is ${from-3.5.1} init-common: init-upgrade: [echo] init-upgrade called for SITEADVMETA from 3.5.0.311 to 3.5.0.328 upgrade-context: upgrade-policy: uninstall-event-parser: upgrade-from-2.0.0: upgrade-from-2.0.1: upgrade-from-3.0.0: upgrade-from-3.0.2: upgrade-from-3.0.3: upgrade-from-3.5.0: [echo] Upgrading from 3.5.0 ... upgrade-db-3.0.3-to-3.5.1: [echo] calling sql/SAE35Patch1UpgradeScript.sql [execute-sql] upgrade-db-3.5.1-to-3.5.2: [echo] calling sql/SAE35Patch2Upgrade.sql BUILD FAILED C:\PROGRA~2\McAfee\EPOLIC~1\server\extensions\installed\SITEADVMETA\3.5.0.328\i nstall.xml:331: The following error occurred while executing this line: C:\PROGRA~2\McAfee\EPOLIC~1\server\extensions\installed\SITEADVMETA\3.5.0.328\i nstall.xml:420: java.sql.SQLException: Violation of UNIQUE KEY constraint 'IX_EPOPolicySettingValues_SettingSectionSetting'. Cannot insert duplicate key in object 'dbo.EPOPolicySettingValues'. The duplicate key value is (1004, Eventing, bDisableEventing). at net.sourceforge.jtds.jdbc.SQLDiagnostic.addDiagnostic(SQLDiagnostic.java:372) at net.sourceforge.jtds.jdbc.TdsCore.tdsErrorToken(TdsCore.java:2985) at net.sourceforge.jtds.jdbc.TdsCore.nextToken(TdsCore.java:2418) at net.sourceforge.jtds.jdbc.TdsCore.getMoreResults(TdsCore.java:674) at net.sourceforge.jtds.jdbc.JtdsStatement.processResults(JtdsStatement.java:614) at net.sourceforge.jtds.jdbc.JtdsStatement.executeSQL(JtdsStatement.java:573) at net.sourceforge.jtds.jdbc.JtdsStatement.executeImpl(JtdsStatement.java:810) at net.sourceforge.jtds.jdbc.JtdsStatement.executeUpdate(JtdsStatement.java:1289) at net.sourceforge.jtds.jdbc.JtdsStatement.executeUpdate(JtdsStatement.java:1242) at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.ja va:43) at java.lang.reflect.Method.invoke(Method.java:606) at com.mcafee.orion.core.db.sqlserver.JtdsStatementRetryInvocationHandler.invoke(J tdsStatementRetryInvocationHandler.java:53) at com.sun.proxy.$Proxy5.executeUpdate(Unknown Source) at com.mcafee.orion.core.db.base.SqlUtil.executeSql(SqlUtil.java:100) at com.mcafee.orion.core.ext.tasks.SqlTask.execute(SqlTask.java:58) at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291) at sun.reflect.GeneratedMethodAccessor995.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(De
          2/3/15 3:18:35 PMFailed to check in extension 'SAE 3.5 Patch 3 Extension'.
          2/3/15 3:18:35 PMCompleted: Check In Components (The component(s) failed to check in.)
          • 2. Re: SAE+ 3.5 Update Extension 3.5.0.328
            Karel

            I've opened a new case with 2 of our Mcafee distributors and both confirmed more complaints.

            I'll see if something pops up.

            Or perhaps this issue is just with the latest patch (3321) and could be solved once Mcafee release a new patch.

            • 3. Re: SAE+ 3.5 Update Extension 3.5.0.328
              jjandebeur

              I contacted Support, they should be updating original post as possible.  They had to work on my DB, unregister and reinstall MSAE.  Good luck on getting your resolution, I am back up and running.

              • 4. Re: SAE+ 3.5 Update Extension 3.5.0.328

                Hi Karel,

                 

                Please follow the below Steps to Resolve the issue:

                 

                1. Take MSAE Policy backup.

                2. Make a note of MSAE Policy Assignment, So that you can assign the policy back to correct subgroup or machine.

                3. Task ePO DB Backup.

                4. Login to ePO Console, GO to Menu - Software - Extension and Try to remove all the Extension for MSAE. You should be able to remove SITEADVCFMETA, SITEADVLICMETA, But SITEADVMETA might give you an Error, Just Ignore and proceed to next step.

                5. Get the sql uninstallation script from the below location on ePO Server, and run it on ePO Database.

                 

                <ePO Install Dir>\Server\extensions\installed\SITEADVMETA\3.5.0.311\sql\Uninstall.sql

                6. Close the SQL Server Management Studio and reopen and Expand ePO DB and check if all the tables related to 'SAE' are removed or not, If yes

                7. Login back to ePO Console and go to Go to Menu - Software - Extension and Try to remove all the SITEADVMETA Extension for MSAE.

                8. Import the MSAE Policies from the back up you have taken in step 1. and restore it.

                9. Assign the policies to respective subgroup and system

                 

                Hope this helps.

                 

                Please reply if the issue is resolved.

                 

                Regards,

                - AJ

                • 5. Re: SAE+ 3.5 Update Extension 3.5.0.328
                  Karel

                  Seems to have done the trick.

                  First hat some more issues but after a few attempts it seemed to have allowed the update to be installed


                  Thanks for the info and help