2 Replies Latest reply on Mar 31, 2015 11:07 AM by vincent.fonteneau

    Is it possible to restart the initial configuration wizard?

    jcl_cls01

      I have a new Web Gateway appliance that I am building and went through the process of upgrading to the latest level.  After the reboot,  the network menu came up to define the ip and I shut down the device because I didn't have the ip's at the moment.  Is there a way to resume the configuration wizard to define the ip's using the menus,  or do I manually enter the ip after logging in and use the Web console? Is there a script I can execute the configuration wizard again?

        • 1. Re: Is it possible to restart the initial configuration wizard?
          Jon Scholten

          Hi jcl,

           

          There isnt a way that I know of to force the menu to come up again. You will likley need to set it from the CLI as it won't have an IP when it comes up. You can set the IP/GW  temporarily from the CLI using the commands below, this will get you to the GUI to set it permanently.

          # Change 'root' password, default is "webgateway":

          passwd

           

          # Temporarily set IP address (Set it permanantly Configuration > [Select your appliance] > Network):

          ifconfig eth0 [DESIRED-IP]/[CIDR]

           

          # Temporarily set default gateway (Set it permanantly Configuration > [Select your appliance] > Network):

          ip route add default via [DEFAULT-GATEWAY-IP]

           

          Best Regards,

          Jon

          • 2. Re: Is it possible to restart the initial configuration wizard?
            vincent.fonteneau

            Hi,

             

            I've had the same problem, and find a solution. here is the steps iIve done

             

            1. Login on console with root account
            2. run the command /usr/bin/mwg-config
            3. follow the steps
            4. run the command /usr/bin/mwg-apply
            5. restart the appliance

             

            You should have your interface and gateway well configured

             

            Regards

             

            Vincent