1 2 Previous Next 13 Replies Latest reply on Nov 24, 2014 5:26 AM by hem

    Cannot install mcafee agent 5.0 on client PC

    prachya

      Hi, I've a problem with mcafee agent 5.0 installing package created by ePo 5.1.1

       

      On server site I have epolicy 5.1.1 server with mcafee agent 5.0 in current master repository (Installed on vmware w2k12r2).

      On client site I have VSE 8.8 with mcafee agent 4.5 (Installed on vmware windows7x64)

       

      In administrator user (built-in user). All firewall on both site are closed

      I've uninstalled mcafee agent 4.5 by run command "framepkg.exe /remove=agent" as administrator and restart my vmware

      every thing ok and then the problem is when I try to install mcafee agent 5.0 by copy folder "0409" from path

      "C:\Program Files (x86)\McAfee\ePolicy Orchestrator\DB\Software\Current\EPOAGENT3000\Install\0409\" on my epolicy server

      to D:\temp and I tried install mcafee agent 5.0 (framepkg.exe from my epolicy server was created by agent 5.0 on master repository)

      by run command prompt as administrators and type this command  "framepkg.exe /install=agent /forceinstall /siteinfo=d:\temp\sitelist.xml"

      I wait for 10 minute but nothing happen then I tried to run this command "framepkg.exe /install=agent /forceinstall" but nothing happen too

      and I install mcafee agent 5.0 by right click on framepkg.exe > Run as administrators but nothing happen too.


      Please help me to install mcafee agent 5.0

      Best Regards

      Prachya

        • 1. Re: Cannot install mcafee agent 5.0 on client PC
          llamamecomoquieras


          Morning,

           

          What happe if you create the agent Package from ePO console like this:

           

          Go to System tree -> System tree actions -> New Systems -> Create and download agent installation Package

           

          Save the file and run it locally (double click) and see what's happens

           

          Best regards,

           

          Jose Maria

          • 2. Re: Cannot install mcafee agent 5.0 on client PC
            prachya

            Thank you for your reply

             

            I tried to follow your instructions but

            It's not work. Nothing happen

            no installation wizard pop up or anything

            • 3. Re: Cannot install mcafee agent 5.0 on client PC
              llamamecomoquieras

              So What happens if you run (Windows key +R) this command in your Machine? msiexec

               

              Do you get a Windows like that?

               

              1.jpg

              Just want to confirm that you do not have the msi installer corrupted..

               

              Best regards,

               

              Jose Maria


              • 4. Re: Cannot install mcafee agent 5.0 on client PC
                prachya

                Yes I got a Windows same as your picture.

                 

                Every thing is fine when I Install agent 4.8 which is a default version from epolicy.

                But it's not work for agent 5.0

                • 5. Re: Cannot install mcafee agent 5.0 on client PC
                  llamamecomoquieras

                  Can you delete the agent 5.0 from the master repository and re- check the Package again? Or you can just re-check the Package in diferent branch..

                   

                  Wich OS are you installing the McAfee agent in? Just to make sure it is supported..

                   

                  Best regards,

                   

                  Jose Maria

                  • 6. Re: Cannot install mcafee agent 5.0 on client PC
                    prachya

                    I've install on windows7 64bit Professional

                     

                    I've already recheck package (MA500WIN.zip with file size 35,814,331 bytes)

                    and recheck in other branch (previous and evaluation)

                     

                    But nothing happen

                    • 7. Re: Cannot install mcafee agent 5.0 on client PC
                      llamamecomoquieras

                      Ok.

                       

                      Do you get any logs under TEMP\McAfeeLogs?

                       

                      Best regards,

                       

                      Jose Maria

                      • 8. Re: Cannot install mcafee agent 5.0 on client PC
                        prachya

                        Yes I've got 2 files in folder %temp%\McAfeeLogs

                        1. FrmInst_Client-PC.log

                        #-------------Run by command : framepkg.exe /install=agent /forceinstall----------------#

                        2014-11-24 15:46:10.850 I #2664 Stub Pkg

                        2014-11-24 15:46:10.850 I #2664 Stub Pkg START [FramePkg.exe  /install=agent /forceinstall]

                        2014-11-24 15:46:10.850 I #2664 Common Pkg CreateDirectory (C:\Users\EPOLIC~1\AppData\Local\Temp\mfe53B7.tmp)

                        2014-11-24 15:46:11.100 I #2664 Common Pkg CreateProcess (C:\Users\EPOLIC~1\AppData\Local\Temp\mfe53B7.tmp\FrmInst.exe, /install=agent /forceinstall /FramePkg /OriginalFramePkg="D:\FramePkg.exe" /Cleanup="C:\Users\EPOLIC~1\AppData\Local\Temp\mfe53B7.tmp" /LOGDIR="C:\Users\EPOLIC~1\AppData\Local\Temp\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword="")

                        2014-11-24 15:46:11.147 I #2664 Stub Pkg Waiting for installation to complete

                        2014-11-24 15:46:11.147 I #2664 Common Pkg WaitForSingleObject (C:\Users\EPOLIC~1\AppData\Local\Temp\mfe53B7.tmp\FrmInst.exe, -1)

                        2014-11-24 15:46:11 I #380 Setup Ins START [/install=agent /forceinstall /FramePkg /OriginalFramePkg="D:\FramePkg.exe" /Cleanup="C:\Users\EPOLIC~1\AppData\Local\Temp\mfe53B7.tmp" /LOGDIR="C:\Users\EPOLIC~1\AppData\Local\Temp\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword=""]

                        2014-11-24 15:46:11 I #380 Setup Ins Windows 6.1.7601 Service Pack 1

                        2014-11-24 15:46:11 I #380 msiFix Ins Finding agent MSI product code

                        2014-11-24 15:46:11 I #380 msiFix Ins Got MSI product code {5C1FBBAF-14C8-4A23-A4A7-BCF19A979890}

                        2014-11-24 15:46:11 I #380 msiFix Ins Finding agent MSI version

                        2014-11-24 15:46:11 I #380 msiFix Ins Got agent MSI version 4.5.0101

                        2014-11-24 15:46:11 I #380 msiFix Ins Nothing to fix for this agent version

                        2014-11-24 15:46:11 I #380 Setup Ins Attempting to perform a setup operation

                        2014-11-24 15:46:11 E #380 Filer Ins Error trace:

                        2014-11-24 15:46:11 E #380 Thread Ins [Main thread]->

                        2014-11-24 15:46:11 E #380 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:46:11 E #380 Filer Ins  Missing MA data path

                        2014-11-24 15:46:11 E #380 Filer Ins Error trace:

                        2014-11-24 15:46:11 E #380 Thread Ins [Main thread]->

                        2014-11-24 15:46:11 E #380 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:46:11 E #380 Cmalib Ins [Update manifest product count]->

                        2014-11-24 15:46:11 E #380 Filer Ins  Missing MA data path

                        2014-11-24 15:46:11 I #380 Cmalib Ins Referencer 1 VIRUSCAN8800

                        2014-11-24 15:46:11 E #380 Filer Ins Error trace:

                        2014-11-24 15:46:11 E #380 Thread Ins [Main thread]->

                        2014-11-24 15:46:11 E #380 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:46:11 E #380 Filer Ins  Missing MA data path

                        2014-11-24 15:46:11 I #380 caShrLb Ins Installed version=4.5.0.1499

                        2014-11-24 15:46:11 I #380 caShrLb Ins Product count=1

                        2014-11-24 15:46:11 I #380 caShrLb Ins Managed mode=0

                        2014-11-24 15:46:11 I #380 Setup Ins Legacy installed=1

                        2014-11-24 15:46:11 I #380 Setup Ins Upgrade supported only from MA 4.6 and above.

                        2014-11-24 15:46:11 I #380 Thread Ins Exit program

                        2014-11-24 15:46:11 I #380 Setup Ins END 1603

                        2014-11-24 15:46:11.272 I #2664 Stub Pkg END 1603

                        2014-11-24 15:46:11.382 I #3152 Main Cle

                        2014-11-24 15:46:11.382 I #3152 Main Cle START [3428 /LOGDIR="C:\Users\EPOLIC~1\AppData\Local\Temp\McAfeeLogs" "C:\Users\EPOLIC~1\AppData\Local\Temp\mfe53B7.tmp"]

                        2014-11-24 15:46:11.382 I #3152 Main Cle Delete on reboot: C:\Users\EPOLIC~1\AppData\Local\Temp\mfe53B7.tmp\cleanup.exe

                        2014-11-24 15:46:11.397 I #3152 Main Cle Delete on reboot: C:\Users\EPOLIC~1\AppData\Local\Temp\mfe53B7.tmp

                        2014-11-24 15:46:11.397 I #3152 Main Cle END 0

                         

                        #-------------Run by right click on framepkg.exe > Run as administrator ---------------------#

                        2014-11-24 15:50:25.444 I #300 Stub Pkg

                        2014-11-24 15:50:25.444 I #300 Stub Pkg START ["D:\FramePkg.exe" ]

                        2014-11-24 15:50:25.444 I #300 Common Pkg CreateDirectory (C:\Users\EPOLIC~1\AppData\Local\Temp\mfe3639.tmp)

                        2014-11-24 15:50:25.710 I #300 Common Pkg CreateProcess (C:\Users\EPOLIC~1\AppData\Local\Temp\mfe3639.tmp\FrmInst.exe, /Install=Agent /FramePkg /OriginalFramePkg="D:\FramePkg.exe" /Cleanup="C:\Users\EPOLIC~1\AppData\Local\Temp\mfe3639.tmp" /LOGDIR="C:\Users\EPOLIC~1\AppData\Local\Temp\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword="")

                        2014-11-24 15:50:25.741 I #300 Stub Pkg Waiting for installation to complete

                        2014-11-24 15:50:25.741 I #300 Common Pkg WaitForSingleObject (C:\Users\EPOLIC~1\AppData\Local\Temp\mfe3639.tmp\FrmInst.exe, -1)

                        2014-11-24 15:50:25 I #392 Setup Ins START [/Install=Agent /FramePkg /OriginalFramePkg="D:\FramePkg.exe" /Cleanup="C:\Users\EPOLIC~1\AppData\Local\Temp\mfe3639.tmp" /LOGDIR="C:\Users\EPOLIC~1\AppData\Local\Temp\McAfeeLogs" /EmbeddedUsername="" /EmbeddedDomain="" /EmbeddedPassword=""]

                        2014-11-24 15:50:25 I #392 Setup Ins Windows 6.1.7601 Service Pack 1

                        2014-11-24 15:50:25 I #392 msiFix Ins Finding agent MSI product code

                        2014-11-24 15:50:25 I #392 msiFix Ins Got MSI product code {5C1FBBAF-14C8-4A23-A4A7-BCF19A979890}

                        2014-11-24 15:50:25 I #392 msiFix Ins Finding agent MSI version

                        2014-11-24 15:50:25 I #392 msiFix Ins Got agent MSI version 4.5.0101

                        2014-11-24 15:50:25 I #392 msiFix Ins Nothing to fix for this agent version

                        2014-11-24 15:50:25 I #392 Setup Ins Attempting to perform a setup operation

                        2014-11-24 15:50:25 E #392 Filer Ins Error trace:

                        2014-11-24 15:50:25 E #392 Thread Ins [Main thread]->

                        2014-11-24 15:50:25 E #392 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:50:25 E #392 Filer Ins  Missing MA data path

                        2014-11-24 15:50:25 E #392 Filer Ins Error trace:

                        2014-11-24 15:50:25 E #392 Thread Ins [Main thread]->

                        2014-11-24 15:50:25 E #392 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:50:25 E #392 Cmalib Ins [Update manifest product count]->

                        2014-11-24 15:50:25 E #392 Filer Ins  Missing MA data path

                        2014-11-24 15:50:25 I #392 Cmalib Ins Referencer 1 VIRUSCAN8800

                        2014-11-24 15:50:25 E #392 Filer Ins Error trace:

                        2014-11-24 15:50:25 E #392 Thread Ins [Main thread]->

                        2014-11-24 15:50:25 E #392 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:50:25 E #392 Filer Ins  Missing MA data path

                        2014-11-24 15:50:25 I #392 caShrLb Ins Installed version=4.5.0.1499

                        2014-11-24 15:50:25 I #392 caShrLb Ins Product count=1

                        2014-11-24 15:50:25 I #392 caShrLb Ins Managed mode=0

                        2014-11-24 15:50:25 I #392 Setup Ins Legacy installed=1

                        2014-11-24 15:50:25 I #392 Setup Ins Upgrade supported only from MA 4.6 and above.

                        2014-11-24 15:50:25 I #392 Thread Ins Exit program

                        2014-11-24 15:50:25 I #392 Setup Ins END 1603

                        2014-11-24 15:50:25.913 I #300 Stub Pkg END 1603

                        2014-11-24 15:50:25.975 I #2120 Main Cle

                        2014-11-24 15:50:25.975 I #2120 Main Cle START [776 /LOGDIR="C:\Users\EPOLIC~1\AppData\Local\Temp\McAfeeLogs" "C:\Users\EPOLIC~1\AppData\Local\Temp\mfe3639.tmp"]

                        2014-11-24 15:50:25.975 I #2120 Main Cle Delete on reboot: C:\Users\EPOLIC~1\AppData\Local\Temp\mfe3639.tmp\cleanup.exe

                        2014-11-24 15:50:25.991 I #2120 Main Cle Delete on reboot: C:\Users\EPOLIC~1\AppData\Local\Temp\mfe3639.tmp

                        2014-11-24 15:50:25.991 I #2120 Main Cle END 0

                         

                        2. FrmInst_Client-PC_error

                        #-------------Run by command : framepkg.exe /install=agent /forceinstall----------------#

                        2014-11-24 15:46:11 E #380 Filer Ins Error trace:

                        2014-11-24 15:46:11 E #380 Thread Ins [Main thread]->

                        2014-11-24 15:46:11 E #380 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:46:11 E #380 Filer Ins  Missing MA data path

                        2014-11-24 15:46:11 E #380 Filer Ins Error trace:

                        2014-11-24 15:46:11 E #380 Thread Ins [Main thread]->

                        2014-11-24 15:46:11 E #380 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:46:11 E #380 Cmalib Ins [Update manifest product count]->

                        2014-11-24 15:46:11 E #380 Filer Ins  Missing MA data path

                        2014-11-24 15:46:11 E #380 Filer Ins Error trace:

                        2014-11-24 15:46:11 E #380 Thread Ins [Main thread]->

                        2014-11-24 15:46:11 E #380 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:46:11 E #380 Filer Ins  Missing MA data path

                         

                        #-------------Run by right click on framepkg.exe > Run as administrator ---------------------#

                        2014-11-24 15:50:25 E #392 Filer Ins Error trace:

                        2014-11-24 15:50:25 E #392 Thread Ins [Main thread]->

                        2014-11-24 15:50:25 E #392 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:50:25 E #392 Filer Ins  Missing MA data path

                        2014-11-24 15:50:25 E #392 Filer Ins Error trace:

                        2014-11-24 15:50:25 E #392 Thread Ins [Main thread]->

                        2014-11-24 15:50:25 E #392 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:50:25 E #392 Cmalib Ins [Update manifest product count]->

                        2014-11-24 15:50:25 E #392 Filer Ins  Missing MA data path

                        2014-11-24 15:50:25 E #392 Filer Ins Error trace:

                        2014-11-24 15:50:25 E #392 Thread Ins [Main thread]->

                        2014-11-24 15:50:25 E #392 Setup Ins [Attempting to perform a setup operation]->

                        2014-11-24 15:50:25 E #392 Filer Ins  Missing MA data path

                        • 9. Re: Cannot install mcafee agent 5.0 on client PC
                          hem

                          Looks like you are upgrading the agent from 4.5 to 5.0

                           

                          2014-11-24 15:50:25 E #392 Filer Ins  Missing MA data path

                          2014-11-24 15:50:25 I #392 caShrLb Ins Installed version=4.5.0.1499

                          2014-11-24 15:50:25 I #392 caShrLb Ins Product count=1

                          2014-11-24 15:50:25 I #392 caShrLb Ins Managed mode=0

                          2014-11-24 15:50:25 I #392 Setup Ins Legacy installed=1

                          2014-11-24 15:50:25 I #392 Setup Ins Upgrade supported only from MA 4.6 and above.

                           

                          MA 4.5 is already EOL -so not sure whether upgrade will work or not.


                          Are you facing the issue with new install also or upgrade from MA 4.6?

                          1 2 Previous Next