3 Replies Latest reply on Oct 29, 2014 6:10 AM by lucavidali

    Workstation startup (McAfee Agent + VSE)

    lucavidali

      Hi,

      I need to deploy some brand new workstation.

      In order to protect them form infection during the configuration (domain join, software and windows update installation, OS configuration) I want to install  the VSE before connecting them to the network.

       

      I copied in an USB pen drive:

      - framepkg (created from epo)

      - VSE install file

      - latest full DAT file downloaded from the mcafee web site

       

      I performed this operation

      1) installed the framepkg (McAfee agent)

      2) installed the VSE

      3) installed the DAT file

      4) reboot the machine to apply the VSE filter driver

       

      During the VSE installation, the installer perfomed the step "installing McAfee Common Framework".. also If I've already installed the McAfee Agent..

      I notice that the McAfee agent is correctly connected to the ePO server also if the VSE has overwrited the common framework.

      Is this a normal behavior?

       

      Is the procedure correct or there are another way to obtain the same result?

      Many thanks

      Luca

        • 1. Re: Workstation startup (McAfee Agent + VSE)
          psolinski

          That's correct order and expected behaviour.

          • 2. Re: Workstation startup (McAfee Agent + VSE)
            llamamecomoquieras

            Hi,

             

            I have something else to add.

             

            You could use the McAfee Installation designer and customize the policies and Settings, so your VSE will be installed with the same configuration than ePO, in case you have any exclusions or diferent Settings.

             

            Best regards,

             

            Jose Maria

            • 3. Re: Workstation startup (McAfee Agent + VSE)
              lucavidali

              Hi Jose!

              In my case I want only to protect the machine during the first phase (domain join, os configuration ecc..), so also if there are no exclusions and the default settings are applied (scan all files, archive ecc..) I'm not worried about performance issues.

              Furthermore, in my case, I don't remove any components (email scanner, ecc..) also from the VSE install task pushed from ePO .Simply I disable it from the policies..

              But this is another topic: which are the best practices regarding the VSE component ? Is better to remove it if unused, or is better to leave it (for future use for example) in the installer and disable it from the policies?

               

              After this phase I will connect the network cable and so the McAfee agent will sync all the policies (Mcafee Agent and VSE) from the ePO.

               

              But yeah, I agree with you, very good suggestion!

               

              Many thanks!

              Luca