1 Reply Latest reply on Oct 4, 2014 9:25 AM by twisted_pony

    MQM 7.0 in a Windows 2008 R2 cluster (VM's) configuration not working (storage location?)

    twisted_pony

      Hi, any help greatly appreciated:-)

       

      Situation:

       

      We have two Windows 2008 R2 enterprise VM hosts in a Windows cluster with IIS installed correctly on both hosts.

       

      We have installed MQM 7.01 RTW  including the v7.0.1 Rollup 1 and Hotfixes HF961781 and HF9955651 on both hosts. We can log onto both MQM services running in non cluster mode (local) and can point our MEG appliance VIP to each MQM individually.

       

      The back end SQL DB has been setup and is working on a separate cluster perfectly.

       

       

      However:

       

      When configuring MQM in a HA as per MQM 700-pg.pdf, Page 21:

       

      Task

      1 Launch the Microsoft Cluster Administrator console.  Complete

      2 Select Services and Application | Configure a service or application. Complete

      3 In Select service or application, select Other Server. Complete

      4 On the Client Access Point dialog box, specify the name and IP address to access the

      MQM resources. Complete

      5 Select Storage used by MQM service to store shared data. Skipped, but added below

      6 Select Resource Type as McAfee MQM cluster framework. Complete

      7 Select the newly configured service. Complete

      8 Select the properties of New McAfee MQM cluster framework .Complete

      9 Click the Properties tab.Complete

      10 For shared_data_drive, specify the value Drive Location to store MQM shared data. Completed using a remote file share using UNC path (with the relevant permissions) and also completed using a local drive and path : D:\shared (Just to see if it was an issue with writing to a UNC share).

      11 Apply the configuration. Complete

      12 Select the newly configured service and click Bring this service or application online. Complete

       

      Issue:

       

      1). The MQM Cluster Administrator GUI is not accessible via the GUI VIP, error indicates that the GUI cannot find its' configuration data..which upon inspection of both locations specified shows that no files are being created. This does not change if we fail over the MQM service to from one host to the other host within the cluster.

       

      Q1: Reference step 10 above, what form should the data path specified take i.e..  UNC path or local drive, clustered disk space or physical disk?

      Q2: How long should it tale for this location to be populated with the configuration data that MQM needs? We are seeing no data being written.

      Q3: Has anyone successfully completed the above scenario (or something similar)?

       

      Thanks,