1 2 Previous Next 15 Replies Latest reply on Sep 12, 2014 7:07 AM by horst

    McAfee agent doesn`t install VSE 8.8 Patch 4

    horst

      Hello,

       

      I have to administer an environment with about 70 WIN 7 x64 client PCs. The PCs are standalone, without a domain or PDC. On the PCs I orginally installed the VSE 8.8.0 (8.8.0.777 - Build date 12.01.2011) manually.

      This worked without problems all the time.

       

      Not so long ago I installed a new ePO 5.1.0 Server to manage the VSE installation on the PCs from a central point.

      To import the clients into the ePO server I installed the FramePkg.exe from the server on every client PC. This worked quite well and after a while all the PCs appeared in the ePO server.

      No I have the problem the McAfee agent on the clients does not install the patch 4 for the VSE 8.8.0 although it is checked in an the client task is configured properly.

      In the client log I only can see something like "The task: 'VSE Patch install' is successfull" and "The task: 'VSE Patch install' has ended".

       

      When I import a new client PC in the ePO server, without any VSE installation on it the McAfee Agent automatically installs VSE8.8.0.1247 including patch 4.

      Also when i uninstall the 8.8.0.777 VSE on one of the PCs from above, the MCAfee Agent automatically installs the VSE again but then including the patch 4?!

       

       

      Now I`m wondering what`s wrong with my configuration?!

       

      Can anybody please help me?

       

       

      Thanks

        • 1. Re: McAfee agent doesn`t install VSE 8.8 Patch 4
          jmcleish

          Hi,

          From the patch 4 readme (included with the package)

           

          Patch version

          • Patch 4 package — Updates VirusScan Enterprise 8.8.0 clients, with Patch 1 (32-bit) or Patch 2 (64-bit) only.

          Important This package does not upgrade VirusScan Enterprise version 8.8.0.777 (RTW).

          To update with the Patch 4 package:

          ◦ On 64-bit systems, first install Patch 2, then Patch 4.

          ◦ On 32-bit systems, first install Patch 1, then Patch 4.

          Alternatively, uninstall VirusScan Enterprise 8.8.0 and reinstall with the Repost

           

          So-you need to do 2 things.

          1. Add patch 2 for 8.8 into the repository and deploy that to all your 8.8.0.777 clients, then

          2. Add patch 4 for 8.8 into the repository and deploy that to all your 8.8.0.975 (8.8p2) clients.

           

          What you have installed is the full package which will not patch an already installed 8.8.

           

          HTH

          Jane

          • 2. Re: McAfee agent doesn`t install VSE 8.8 Patch 4
            Richard Carpenter

            Hey,

             

            If the point product is already in place, you can check the Patch package into your Master Repository and update all your endpoints using a Product Update Task, maybe the same one as the task used to update your signature definitions (DATs).

             

            If you enable the 'VirusScan Enterprise 8.8.0' option in the Product Update task it will update the endpoint with the inplace upgarde, again noting Jane's comments about version compatibility.

             

            Regards

             

            Rich

            Certified McAfee Security Specialist — ePO

            • 3. Re: McAfee agent doesn`t install VSE 8.8 Patch 4
              exbrit

              Moved this to VSE as a better spot for it.

              Peter

              Moderator

              • 4. Re: McAfee agent doesn`t install VSE 8.8 Patch 4
                horst

                Hi,

                 

                thanks for your replys so far!

                I´ve already been thinkin in this direction. Here`s a screenshot of my Software Manager:

                 

                vse.jpg

                 

                So just for my understanding. To resolve my problem I have to check out the Patch 3 and Patch 4. Then the Clients should install Patch 2 automatically.

                Referring to this I check in Patch 3 and 4 again and then the Clients should install Patch 4 automatically.

                 

                Is this correct?

                 

                 

                But what happens with the Clients on which Patch 4 is already installed when I ckeck it out in the Software Manager?

                Will they automatically uninstall this one then?!

                • 5. Re: McAfee agent doesn`t install VSE 8.8 Patch 4
                  jmcleish

                  Hi,

                  From that info, looks like you don't have any patches installed.

                   

                  You should be able to check in both patch 2 and patch 4 and when you enable the option for patches in the product update task like Rich stated earlier, it should run both patches, but only install the one that is valid.

                   

                  (When you remove a package from the repository, it doesn't uninstall on the client- you'd need to change the task to remove instead of install.)

                  • 6. Re: McAfee agent doesn`t install VSE 8.8 Patch 4
                    horst

                    hmm, but as I wrote in my first post I already created an update Task loooking like this:

                     

                    vse2.jpg

                    In the client log of th McAfee Agent I only can see something like "The task: 'VSE 8.8.0 Patches...' is successfull" and "The task: 'VSE 8.8.0 Patches...' has ended".

                    But the Client doesn`t install one of the patches.

                    • 7. Re: McAfee agent doesn`t install VSE 8.8 Patch 4
                      llamamecomoquieras

                      Hi there,

                       

                      Can you please confirm:

                       

                      Does those Machines have VSE 8.8 patch 2 installed?

                      How many Machines do you have the problem with?

                      Can you please attach the installation log from %temp%\mcafeelogs?

                      Can you please attach a screenshot from your master repository?

                      Can you please check the MA policy to make sure that the policy point to the right branch and you not pointing to corrent or previous if for exemple the Package is in evaluation?

                       

                      Best regards,

                       

                      Jose Maria

                      • 8. Re: McAfee agent doesn`t install VSE 8.8 Patch 4
                        horst

                        some more screenshots:

                         

                        the master repository:

                        master.jpg

                         

                         

                        Client with the manually installed VSE, not applying any patch:

                        vse-client.jpg

                         

                         

                        one of the Clients from above, on which I uninstalled the VSE manually and the McAfee Agent installed VSE again automatically:

                        vse-client_2.jpg

                        • 9. Re: McAfee agent doesn`t install VSE 8.8 Patch 4
                          llamamecomoquieras

                          Well,

                           

                          In the Machine with patch 0 installed will not install patch 4 straight away as you must have at least patch 2 as previously it was said.

                           

                          Patch version

                          • Patch 4 package — Updates VirusScan Enterprise 8.8.0 clients, with Patch 1 (32-bit) or Patch 2 (64-bit) only.

                          Important This package does not upgrade VirusScan Enterprise version 8.8.0.777 (RTW).

                          To update with the Patch 4 package:

                          ◦ On 64-bit systems, first install Patch 2, then Patch 4.

                          ◦ On 32-bit systems, first install Patch 1, then Patch 4.

                          Alternatively, uninstall VirusScan Enterprise 8.8.0 and reinstall with the Repost

                           

                          I am sure if you try manually to install patch 4 an error message will pop up saying that cannot be installed.

                           

                          Try in a single Machine to install patch 2 or 3 manually and then run again the task of patch 4

                           

                           

                          Keep us posted!

                           

                           

                          Best regards,

                           

                          Jose Maria

                          1 2 Previous Next