1 2 Previous Next 13 Replies Latest reply on Sep 23, 2014 4:37 AM by evgeny.borisov

    Problem with Mirror task from ePO

    evgeny.borisov

      Hello.

      We have a small network here, with ePO installed. It takes updates from McAfee http source, all correct. Stations update their VSE from ePO - no problems. But server with ePO has VSE also, and this VSE has a Mirror task. Mirror is made from ePO software base. Local copy of updates needed - I send it via remote administration to stations, that have no access to ePO.

      The problem is that several days ago Mirrors tasks stopped. Error. But regular updates go fine. I re-created a folder for Mirror files. Ii always had some files in root, and 2 folders - previous & current. Now it has only current, and it has only few folders - less than always had.

      I tried Mirror tasks from another stations - also failed. But updates go fine, without errors...

      Why mirror tasks stopped? Couldn't find any reasons in logs.

        • 1. Re: Problem with Mirror task from ePO
          Peter M

          Moved to ePO for better handling.

           

          Moderator

          • 2. Re: Problem with Mirror task from ePO
            llamamecomoquieras

            What about if you try the mirror task to get the Package from FTP?

             

            What about if you type in the machine which fails in the IE browser http://update.nai.com/products/commonupdater can you reach the Package? Do you have any kind of authentication? Do you have any error with Firewalls/proxy?

             

            Best regards

             

            Jose Maria

            • 3. Re: Problem with Mirror task from ePO
              evgeny.borisov

              Thanks for your attention to my problem, sorry for my bad English though.

               

              Unfortunately, our ePO server cannot go through FTP. It goes to the world via Cisco firewal, and only HTTP allowed.

               

              On machine which fails, I can open the link in browser, and I can download files from there - I reach the Package.

               

              No authentication needed, as far as I know - firewall just allows us to see Mcafee, Microsoft, and several other sites.

               

              I tried this thing: via FTP client I downloaded the whole package on the "full Internet" machine. Copied the base to the "problem" computer. Made my files as a Local repository. Started update - done. Started mirror - error. Some more folders created in "current" folder, but I still have error.

              I don't know how it's possible - "good" update but "bad" mirror from the same source.

              • 4. Re: Problem with Mirror task from ePO
                llamamecomoquieras

                No problema it is pleasure to help

                 

                No worries, my English could be horrible too

                 

                Well it could be possible if the VSE packages needed for the Update has been downloaded ...

                 

                Ok, so let's start with the troubleshouting

                 

                We need to enables McAfee agent debug loging:

                 

                https://kc.mcafee.com/corporate/index?page=content&id=KB58966

                 

                Now, we need to reproduce the issue again.

                 

                Can you please collect the McAfee agent log to check if we can find some clear error which could give us some more info?

                 

                Please, upload the log when ready.

                 

                Best regards,

                 

                Jose Maria

                • 5. Re: Problem with Mirror task from ePO
                  jmcleish

                  Why don't you use ePO to create a distributed repository and disable that repository in the McAfee agent\repository policy for the clients?

                  That way you can use ePO's infrastructure to place the files on machine. You can also select which packages you want to copy to it, so you can reduce the size of the file structure. We have a similar scenario and use this method.

                   

                  HTH

                  Jane

                  • 6. Re: Problem with Mirror task from ePO
                    evgeny.borisov

                    Thanks for your opinions! Now week-end started, so I'll try to start logging in working days.

                     

                    About distributed repository - yes, I thought about that, and maybe I'll try - but it will be completely another method. Now I want to solve, why my mirror task worked earlier - and now not working, or working partially (some files appear locally, but that's all finishes in error).

                     

                    Now one more thing I done recently. I made a full local copy of ypdate package from McAfee FTP via FileZilla client. I did it at home, on my own PC - without any firewalls. Then I moved it to a machine with VSE 8.8.4 installed locally. This machine has never been under ePO, just local VSE. I pointed to my downloaded files as a update source. Started Update - Done. Started Mirror - Fail!! Why? No ePO, no McAfee Agent, just full set of files and local VSE. And mirror failed.

                     

                    I'm beginning to think that something changed in update repositories, something that crashes mirroring. In my main problem, yes, there can be errors - Firewall, ePO, Agents - there is place for mistakes. But in my experiment... no place for errors. And mirroring still fails.

                    What do you think?

                    • 7. Re: Problem with Mirror task from ePO
                      llamamecomoquieras

                      The debug login can give us more info I though.

                       

                      Please, keep us posted.

                       

                      Best regards,

                       

                      Jose Maria

                      • 8. Re: Problem with Mirror task from ePO
                        evgeny.borisov

                        Hello!

                        I've made everything as in KB article about start logging - changed 3 keys in Windows registry. Then started mirror task again, it failed as usual, but no new files appeared in my "C:\Documents and Settings\<username>\Application Data\McAfee\Common Framework\DB\Support DLL\DebugTraceFiles\" folder - only some old txt logs from 2011 year. Maybe logs are stored in some other place? Or my server needs reboot to start logging? No help about it found in KB article.

                        • 9. Re: Problem with Mirror task from ePO
                          jmcleish

                          Do you really need to use a mirror task?  I gave up using them ages ago as i always had issues with them.

                           

                          Setup a distributed repository and see how that goes. Plus you can just download what you need.

                          1 2 Previous Next