1 Reply Latest reply on Sep 9, 2014 1:53 AM by toth.laszlo.1984

    MWG 7.4.2.2 SOCKS Proxy

    harry82

      Hi,

       

      I'm trying to restrict my SOCKS Proxy on source IP, destination IP and destination port.

       

      In MWG 7.3.x the configuration was made in the sockd.conf file.

      ...

      pass {

              from: 1.1.1.1/32 to: 17.0.0.0/8 port=2195

              protocol: tcp

              }

      ...

       

      I assume configuration of sockd.conf is not working in MWG 7.4.2.2 anymore and I have to configure the SOCKS Proxy via Rule Set.

       

      Here is what I did:

       

      • Enabled Socks Proxy (under Configurations listening on 1080)
      • Created a Ruleset SOCKS
        • Connection.Protocol equals SOCKS (checked request)
          • URL.Port does not equal 2195 -> Block (allow only port 2195)
          • Client.IP equals 1.1.1.1 AND URL.Destination.IP is in range list 17.0.0.0/8-> Stop Ruleset (allow 1.1.1.1)
          • Always -> Block (Block everything else)

       

      Unfortunately this Ruleset is not working. Connection is getting blocked.

       

      After removing URL.Port and URL.Destination.IP from the Ruleset, I was able to Connect via SOCKS Proxy. However I also need to restrict on destination and port.

       

      Any Idea how to restrict on all properties (source, destination, port)?

       

      thanks!